4

When I connect a USB 2.0 Lumidigm fingerprint sensor to any of a PC's USB 2.0 ports, both Windows and Linux won't detect it. It doesn't try to install any drivers, and doesn't detect a hardware change. Windows Device Manager and Linux lsusb don't detect it.

Strangely, whenever I connect the device to an unpowered USB hub and I connect the hub to the PC, it gets detected and works perfectly.

The same thing happens with all other USB ports on the PC (there are 4).

Now my question is: How can I fix this problem? The fingerprint reader must be plugged in directly, without the hub.

Some additional questions that might be interesting:

  • How does Windows detect that a USB device is plugged in?
  • How will Windows react differently to a USB hub instead of a regular device?

Everything is using USB 2.0

Edit 1: I have tried to test it on other PC's, and every PC of the same model has that problem. On all of the other PC's and my own this problem doesn't occur. Using an USB extension cord doesn't change anything about the results.

Edit 2: The fingerprint sensor only has a USB mini input. I use a USB mini to USB A cable to connect the device with the PC. This cable works with other devices and the same PC so it cannot be that the USB connector pads don't connect

Edit 3: This issue is still not solved. If I connect the cable with another device, it detects that device, so it's definitely not the cable.

  • Is this a powered hub? – Eugen Rieck Nov 26 '18 at 10:38
  • Is the USB connector (directly on the PC) USB 3.0? I have seen such things with Gemalto Hardware. – Eugen Rieck Nov 26 '18 at 10:41
  • Try a different PC (not installing the driver just if it sees the device) and tell us the vendor. Gemalto devices are sometimes quite picky and don't accept all USB connectors. – Eugen Rieck Nov 26 '18 at 10:45
  • One experiment to find out if this is a Windows problem or a hardware problem would be to boot Linux, e.g. from an USB stick, and see what happens when you plug it in (look at dmesg and lsusb). – dirkt Nov 26 '18 at 11:30
3

Looks like the subcontractor who made the USB female connectors on that one model of PC made them short, out of spec. The fingerprint sensor connectors are just a little too short for the connectors on those motherboard and/or chassis ports, but the USB hub connectors are long enough. You verified that by trying the sensor on a different model of PC.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.