0

Ok, So first things first: I know what a subnetmask is, and what it is used for. But I have no idea how to properly set it

Home network setup

Above is my home network, I have my dhcp server set to the router (192.168.0.1) for all parties involved (Nas, laptop, desktop), and they can all see 192.168.0.1, but they cannot see each other.

What I wish to accomplish is that the laptop can see the NAS, which it at the moment cannot. Because all the IPS on the wireless router get an ip in the 192.168.1.* range, and without the proper subnet they cannot see the ones on the 192.168.0.* range (except the dhcp server apparently)

I cannot set the subnet mask according to what I want: 255.255.252.0 to get the appropriate level of access to different subnets. Do I need some kind of setting to set the wireless router and modem to a class B network?

Is this not something normal networking equipment can handle?

  • 3
    Please work on clarifying this. (1) You say "I have my DHCP server set to the router (192.168.0.1)", but your picture shows two (or three?) routers. (2) You say "they can all see 192.168.0.1", but then you say "they cannot see the ones on the 192.168.0.* range (except the DHCP server apparently)". So which is it? Can the laptop ping 192.168.0.1 or not? (3) You say "I cannot set the subnet mask according to what I want: 255.255.252.0 to get the appropriate level of access to different subnets.", but you don't describe what you want. … (Cont’d) – Scott Nov 26 '18 at 19:48
  • (Cont’d) …  Please do not respond in comments; edit your question to make it clearer and more complete.  P.S. I believe that 255.255.255.0 is probably the netmask you want. – Scott Nov 26 '18 at 19:48
1

The real solution you need is to stop doing double NAT.

You don't want your wireless router acting as a NAT gateway/router. You want it to act as a simple AP (which just bridges frames between wireless and wired). Right now you're doing double NAT, and have two subnets on a network that should be one big flat single single subnet.

If your wireless router allows you to disable NAT and the DHCP server service, do that. If it doesn't allow you to disable NAT, then just disable its DHCP server feature and connect it to the upstream switch via a LAN port instead of the WAN port.

1

There are a number of ways of solving your problem.

The method I would suggest would be to flatten the network by converting your Wireless router into a Wireless access point. You can do this by (a) disabling DHCP on it and (b) disconnecting the WAN Interface and connecting a LAN port to the main router. In this way all your devices will be on the same subnet and be able to reach and see everything else without any routing happening.

Alternatively you can connect the routers together such that they talk to each other. To do this you need to give the wireless router a static WAN IP, and then set a route in the main router for the 192.168.1.0 netmask 255.255.255.0 to the WAN IP of the wireless router. If your netmask on the wireless router is larger then 255.255.255.0 you may need to fix this. You may also need to disable NAT on the WIFI router. This will work in as much as systems will be able to communicate with each other, but it assumes you are using IPV4 and not doing any discovery - for example printers on different subnets will need to be given a static IP and manually set up rather then using drivers.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.