0

I made an attempt to follow procedures at LFS to build a linux system and somewhere along the way i messed up my dual boot or grub setup.

I made a new partition (/dev/sda8). Tried to mount the partition and mkdir(s), but the operations failed. I then added the partition to the /etc/fstab file. Commands still would not execute, I obviously had done something wrong. I deleted the partition with fdisk. I removed the entry from /etc/fstab. After rebooting, windows booted without an option for ubuntu mate. Pressing "esc" shows ubuntu and windows, but selecting ubuntu provides only a grub> prompt. Going through the motions in grub, gets me nowhere. It is unable to recognize the file system my ubuntu install is on (/dev/sda7) and is unable to locate vmlinuzx.x.x. Am I looking at a complete reinstall or is this salvageable? TIA

0

Solved by downloading "grub boot repair" and flashing the ISO to a usb drive. Following the on screen prompts allowed me to boot into ubuntu-mate. I have to "esc" into the boot menu to select "ubuntu" from a massive new grub list, or else it boots straight to windows. I'll take it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.