I recently uninstalled OneDrive because of the issues I was having with it and now whenever I save a file it goes to OneDrive instead of my PC. I can see the file on my desktop but when I check its location, it shows up as C:\Users*user*\OneDrive\Desktop instead of C:\Users*user*\Desktop. I would like to save it to my PC (hard drive) without OneDrive interfering in any way.

Other I have checked the storage in system settings and PC is the only place it can save files which is even more absurd, I unchecked autosave to OneDrive before I uninstalled it as well.

1 Answer 1


This is a side-effect of OneDrive's folder protection feature. It has moved the location of your Desktop into the OneDrive folder. If OneDrive is not running, then it isn't able to upload the documents, so they remain only on your computer. This answer goes into more detail.

The simplest way to revert the location of your Desktop is to:

  1. Open Windows Explorer (Win + E)
  2. Right click the Desktop folder under This PC
  3. Click Properties
  4. Click the Location tab
  5. Click Restore Default
  6. Click OK

Desktop folder properties


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .