This question already has an answer here:

I'm trying to convert an SSD from MBR to GPT when installing Windows 7 so I can use UEFI rather than Legacy boot mode.

I realize there are a few related questions here but I didn't find them particularly helpful. One of the suggestions I've read is to enable UEFI in the BIOS settings but I don't see any option to do that.

Under boot order in the BIOS settings the following devices are listed under EFI boot sources:

  • USB Floppy/CD
  • USB Hard Drive
  • ATAPI CD/DVD Drive

My SSD is listed under Legacy boot sources.

The SSD is in a HP Compaq 8200 Elite SFF PC (64 bit) and I'm installing Windows 7 Professional (64 bit).

I downloaded the Windows 7 ISO image file and created a bootable USB drive using the Windows USB/DVD download tool.

During the installation process where I'm asked to select the drive where Windows will be installed, I deleted all the drives so there was just one unallocated volume left.

I then opened the command line interface and first cleaned the disk and then converted it to GPT using the diskpart prompt. This was reported as successful. I continued the installation allowing a new volume to be created automatically.

After finishing the installation I opened the disk management tool, right clicked on the volume where I had just installed Windows, selected "properties", then the "volume" tab where I saw that the "partition style" was still listed as "MBR".

Also, when checking the boot order in BIOS, the drive is still listed under the Legacy boot mode devices.

marked as duplicate by Ramhound, Pimp Juice IT, Dave M, DrMoishe Pippik, K7AAY Nov 30 at 21:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    You should not be trying to manually convert the unallocated partition to GPT, instead of allowing the installation environment, to simply use the partition schema that will work. The method you describe will not work. All you have to do is enable UEFI only mode, boot to the installation environment, and select the unallocated space. The partition style went back to MBR due to the mode the installation environment was booted into. If you boot into Legacy mode, Windows can only be installed, on an MBR partitioned disk. – Ramhound Nov 29 at 3:30
  • @Ramhound I don't see any option in the BIOS settings to change the boot mode to UEFI. – jrcollins Nov 29 at 7:11
  • 1
    It’s either listed as UEFI or you disable Legacy or equivalent mode. If you cannot disable Legacy/Compatibility Mode/ect. then you cannot install Windows on a GPT. All Windows 8+ machines had to support UEFI but depending on the age your Windows 7 machine might not support it. – Ramhound Nov 29 at 12:41
  • @Ramhound I would have thought the fact that UEFI is listed in the boot order means that it's possible to boot in UEFI mode as long as there is a compatible GPT formatted drive connected? – jrcollins Nov 29 at 20:50
  • 1
    Your problem is either your boot configuration (Legacy vs UEFI) being enabled or your installation media is not UEFI compatible (so it boots into a legacy as a fallback). You indicated there wasn't a UEFI only mode. I am only going off on the information you provided. I just know that making the system disk GPT before you install Windows (while the installation environment is in legacy boot mode), will not result in a working Windows installation, on a GPT partition since Windows can only be installed on MBR partitions while in legacy mode. – Ramhound Nov 29 at 20:58

EFI boot sources contain "known" boot options. As you have not installed Windows for UEFI yet it has not been added. For the purpose of Installation of Windows 7 you need to use EFI boot option based on source of installation media - USB / DVD. Once the installation will be sucessfull it will be added to the list.

GPT partition may be required to be available at the moment of installation process. In that case you can use diskpart to prepare the partition.

You can take inspiration and how-to in this nice article on Microsoft Docs website. It is related to Win 8.1 but the information stated there in this context would be useful also for your case.

Good luck with instalation!


edit - (important steps from referred link):

  • boot the installer (USB / DVD) in UEFI mode (this is very important part as in case of legacy/BIOS boot the installer will have a different behaviour in this context).

  • once you will see "welcome" window of the installer press Shift+F10 to open the command line.

    • run the application

      diskpart

    • Identify the disk using the command

      list disk

    • Select the drive, and reformat it

      select disk <disk number> clean convert gpt exit

    • exit the command line

      exit

  • continue with regulat installation

Not the answer you're looking for? Browse other questions tagged or ask your own question.