1

I can't for the life of me figure this out...

I've installed Mint 19 with Cinnamon on VirtualBox 5.2.22 (latest version I believe) and after installation, I then installed VirtualBox guest additions 5.2.22 using Devices -> Insert Guest Additions CD. After rebooting, I'm apparently still running in software rendering mode. My 3D acceleration is enabled and I've given the system 128mb of video memory. I've never been able to get Cinnamon to work in VirtualBox, but I can't figure out what I'm missing... Any suggestions?

Thanks!

4
  • known bug: virtualbox.org/ticket/11881 – Ipor Sircer Nov 29 '18 at 3:38
  • And hasn't been fixed in 5 years? Someone else recently sent me a VirtualBox machine running Cinnamon on Debian and that machine doesn't give me this error... And I can't get Cinnamon running on Debian either. Don't know why – Myles Nov 29 '18 at 3:43
  • Then ask him for the solution. – Ipor Sircer Nov 29 '18 at 4:53
  • I can't get ahold of him. I thought someone here might know a workaround. Thanks anyways – Myles Nov 29 '18 at 14:48
0

I am able to get Linux Mint 19 Cinnmon running in VirtulBox 6.0.4 without the "Rendering software mode" by changing the display settings. After installing Linux Mint VM, shut down the VM. Then for this VM, go to Settings->Display, set Graphics Controller drop-down to "VBoxVGA" and click the checkbox next to "Enable 3D Acceleration" (DO NOT enable the 2D acceleration, it won't work).

2
  • I don't think I have a Graphics Controller drop-down box... At least not in Settings -> Display. Is there something I'm missing? – Myles Apr 25 '19 at 1:58
  • This will stop working from virtualbox 6.1 – John Oct 11 '19 at 14:21
0

once in Mint go to virtual box menu and install Vbox additions

once that is run select full screen mode (Vbox menus) then shutdown and start.

In Vbox machine settings select VMSVGA and check 3D acceleration box. Don't select 2D. start your machine.

You should not see software render mode notification.

Here is a link to the video that helped me https://www.youtube.com/watch?v=8MIYB0VjQJA

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.