0

I've been trying to get armitage working for a while now and I cant seem to find the exact answer to the problem I'm having so here goes.

When I open armitage it fails to connect to the database and says password auth. failed for user "msf". I have enabled the postgresql service I cannot start the metasploit service as it says service not found metasploit framework is installed and working, but after a restart it goes to password auth. failed for user "msf"

Edit: I'd try reinstalling postgres but when i try to apt install --reinstall postgresql it tries to uninstall kali-linux-full as well.

I have ran msfdb init.

I have ran msfupdate.

I have reinstalled metasploit framework from their website.

I have no clue what is wrong.

  • have you read through this guide from Armitages creator? Starting-guide – Nordlys Jeger Nov 29 '18 at 17:34
  • Yes I have it didn't really help me at all. – Tyler Nov 29 '18 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.