0

I am getting a 2000ms latency delay on HTTP/HTTPS connections on a Windows 10 laptop. At first I thought it was the ISP because telnet connections from the same box were instantaneous. However I connected a Linux machine and did a wget timing to the router and it was more or less instantaneous (<50ms). So, it has to be something on the Windows 10 box. Note that the laptop is using the wireless as opposed to a wired connection for the Linux box, but remember than any non-HTTP packet from the windows box has no latenHcy, so I don't think it is a hardware issue. There appears to be something on the laptop which is causing connections to lag for some reason.

How can I further investigate the cause?

5
  • 2
    How are you measuring this delay? The delay is between what and what exactly? Are you actually measuring with a browser? Nov 29 '18 at 17:56
  • I'm voting to close this question as off-topic because OP observed the issue was resolved after performing several actions, giving us no way to tell which action solved the problem and therefore no way to know what the problem actually was. Dec 5 '18 at 17:26
  • @music2myear Maybe there is no way for YOU to know what the problem was, but somebody who is expert in Windows could potentially look at the three things done and the symptoms and know which one was decisive. Dec 5 '18 at 17:32
  • The problem is that an expert in Windows would not be coming here asking this question, the information you have provided as an answer would be useless to them. Instead, people who are not experts will come looking for solutions and will not have that expert knowledge to decipher what aspects of the information you have given is or is not helpful, and more importantly, what is potentially harmful (disabling your firewall?). Dec 5 '18 at 17:36
  • Note, this is NOT in any way detracting from the validity of your question: You had a real problem and it is now fixed. The problem is that, for this site, we were never able to determine the actual problem or the real cause, and so closing this question as it has been is helping people know that this specific information is unlikely to be useful in solving their own problem. Dec 5 '18 at 17:37
0

I tried a number of things and one of them worked. Here is what I did for reference:

1) turned off auto-tuning (no immediate effect)

2) turned off Windows update setting that allows updates from multiple computers (no immediate effect)

3) turned off Windows firewall completely (no immediate effect)

Restarted the machine and the problem was gone, now getting instantaneous HTTP requests. Since the problem was only affecting HTTP, my guess is that it was some kind of filtering going on in Windows Firewall.

Not the answer you're looking for? Browse other questions tagged or ask your own question.