I made a live USB Installation of Kali Linux which I need for one of my classes. I booted it (UEFI) on my Windows 10 Dell XPS and used the persistence mode since I assumed it would store my changes (keyboard layout, wifi etc.?) on the usb-stick which would be neat.

It worked fine but after I removed it and went back to my windows installation I got a static blue screen: "The Boot Configuration Data file is missing some required information". I also noticed the SSD, on which the Windows installation resides, only shows up under Legacy and not under UEFI. I will include a picture of the partitions I could see with a Windows Boot stick and the error I get.

What did I do wrong?

After checking the drives I think my data is still all there but the repair doesn't work and it still refuses to boot. The drive letters are all messed up. Is this a result of booting the Windows Image USB or an actual problem?

Error Message


  • The easiest fix is to use a recent disk image to repair boot. Macrium Reflect even has an option to just replace the boot sectors. Commented Nov 30, 2018 at 0:56

1 Answer 1


I tried a lot and there are many different suggestions out there but here is what worked for me in the end:

  1. I made a sector by sector clone of the current machine with Acronis True Image
  2. I restored the last Windows Image I had of the machine
  3. I took the backup from 1. and overwrote everything from 2 but the boot sector

Somehow that worked and I have the current state of my machine back. The boot sector was from half a year ago but that did not matter because these things rarely change.

One thing I know for sure: I won't touch Linux Live for a while.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .