I have a Zabbix configuration problem here in the company a few days ago. I'm having this error on the hosts page in the Settings portion. I have already done several tests, being:

  1. Agent and Server Ports Release (Firewall Disabled)
  2. I changed the settings of agent.config and server.config.
  3. I disabled SELINUX.

Agent and Server Ports Release (Firewall Disabled) I changed the settings of agent.config and server.config. I disabled SELINUX. If you can help me thank you, I only need this communication so I can proceed with the finalization of the installation.

Error: Received empty response from Zabbix Agent at [X.X.X.X]. Assuming that agent dropped connection because of access permissions.

I already looked for solutions in google but I did not find answers

UPDATE: I noticed that the server apparently has some network problem. I have managed to install normal zabbix using yum in Centos 7. However, the server is taking too long to ping google.com and is missing the settings in the resolv.conf file.

I do not know what this network problem can be, I'm a beginner in linux and I'm having a bit of trouble correcting this without having to configure a new server.

UPDATE 2: I identified that the server did not contain the google DNS (8.8.8.8) configured in: /etc/sysconfig/network-scripts/ifcfg-eth0 so I added this registry and it solved the network problem, now it's ping google.com , before of this was only the internal DNS of the company. But the initial problem still persists and I think there may be some relationship with network configurations

Configs: SERVER CONFIG, AGENT CONFIG

up vote 0 down vote accepted

Zabbix agent configuration file must allow connections from the server - see the Server configuration parameter.

In this particular case, your agent is more recent than the server (Message from ... is missing header). Try with an version agent that matches the server.

  • Your answer did not help much, I already checked these settings, could be more specific? – Luis Fernando Nov 30 at 19:08
  • Please describe in detail what exactly you checked, and what was observed. If that does not highlight the cause, consider increasing agent log level - then it will print messages about incoming connections, including the IP address it sees. You might have a misconfiguration, unexpected outgoing IP or NAT, among other possible causes. – Richlv Dec 2 at 14:56
  • So, I checked the port settings on windows, I got to disable the firewall and Kaspersky that was running. In addition, I noticed that when I telnet from port 10050 from the server to the agent it connects but then returns the message: "Connection closed by foreign host." next, I disabled Firewalld in CENTOS 7 and confirmed the SELINUX disabled again. The agent log has the following information: Agentd log – Luis Fernando Dec 3 at 16:05
  • In this particular case, your agent is more recent than the server (Message from ... is missing header). Try with an version agent that matches the server. – Richlv Dec 3 at 20:16
  • Hello, I was able to resolve adjusting version of Agent with that of Server, they really were different. Although I managed to resolve before your response, I approved of it being correct. Thanks a lot for the help! – Luis Fernando Dec 5 at 11:24

This error is not a permission error or a server side error. this one related to network hops, First enable debug level in your zabbix agent conf, nano /etc/zabbix/zabbix_agentd.conf UN-comment this line and change it to number 4 Debug Level=4 then restart your agent service tail the log file tail -f /var/log/zabbix/zabbix_agentd.log if your log shows any rejected IP hop, you need to white-list that IP on your agent conf file in two places. server=zabbixserverIP,LasthopIP ServerActive=zabbixserverIP,LasthopIP

in this case main thing is, in your zabbix serverIP range what is the first network hop in your routing, that IP you need to white-list.

Thank you.

  • That's not entirely correct, and listing multiple addresses when only one would be needed could be adding to the confusion. – Richlv Dec 6 at 18:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.