2

I have a weird problem, for which I researched a lot, but no luck!

I have created an External Switch in Hyper-V, which in turn creates a network bridge on my Wifi adapter. I'm facing this issue that, for a specific Website, when I try to go to the login page, I see the ERR_SSL_BAD_RECORD_MAC_ALERT error in Chrome.

I have attached a screenshot: the Website is also there, in case it helps:

enter image description here

It's worth noting that if I right-click on my Wifi adapter and select Remove from Bridge, I don't get this error (of course after a required restart so that my connection works)

I have also included a screenshot of my network adapters and the Properties page of the network bridge; maybe that would help:

enter image description here

Any help is really appreciated.

Thank you

  • Possible duplicate of Google account gives ERR_SSL_BAD_RECORD_MAC_ALERT errors – Ramhound Nov 30 '18 at 22:14
  • What? I linked to a 6 year old duplicate question. – Ramhound Dec 1 '18 at 0:04
  • @Ramhound - I have the exact same problem for a few weeks now. I don't think this is the same error at all. Note it only happens when using the "network bridge" pseudo adapter. Unless you know how to change how this thing work? Can we configure some MTU for this bridge? It does that on all browsers. But, for information, if I use Firefox and set the its security.tls.version.max config option to 1 (default is 4), it works. Weird. – Simon Mourier Dec 1 '18 at 10:12
  • I actually found something that sems works for me... Go to the vEthernet that correspond to your bridge, edit its properties and configure the "Hyper-V Virtual Ethernet Adapter". Change the "Large Send Offload Version 2" to Disabled for IPV4 and IPV6. Here is an image of the dialog box: i.imgur.com/j36AWlE.png – Simon Mourier Dec 1 '18 at 11:16
  • @SimonMourier your workaround worked for me too :) . The question is: is doing that dangerous and causes my connection to be less secure? I'm asking because I have no idea what that Large Send Offload Version 2 does – Farzad Dec 2 '18 at 15:56
1

It seems to be related to the "Hyper-V Virtual Ethernet Adapter" configuration.

Go to the vEthernet pseudo adapter that correspond to your network bridge, edit its properties and configure the "Hyper-V Virtual Ethernet Adapter". Change the "Large Send Offload Version 2" to Disabled for IPV4 and IPV6, like this:

enter image description here

You don't have to reboot, it should work as soon as you accept this new configuration.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.