0

I am trying to start Circuit Construction Kit DC v3.19 because a bit later than that they made an HTML5 version that starts in a browser, and I want the non-HTML version, the one that doesn't use a browser to open.

I see it's a jar file.

So I start it with java -jar circuitconstructionkitdcen319.jar and it gets stuck here, it just hangs, the bar keeps moving left and right but it never finishes loading.

I found it and downloaded it from http://www.brothersoft.com/circuit-construction-kit-(dc-only)-307097.html

I have tried to run it on two different computers and run into the same problem. One computer runs java 1.8, the other also java 8 / 1.8, from https://portableapps.com/apps/utilities/java_portable Both run into the same problem. So I think people will find the problem easy to reproduce.

enter image description here

0

Looks like that was just an issue with 3.19 and 3.20 fixed it, and 3.20 is available here

https://phet.colorado.edu/en/simulation/legacy/circuit-construction-kit-dc

That said, now I can start it,

enter image description here

I see that while the program includes a voltmeter and ammeter, it doesn't even have an Ohmmeter so it's a ridiculously limited learning tool.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.