0

I am currently using ZeroTier VPN to connect two windows 10 computers.

We can see eachother on the network browser, we can ping eachother and we also can connect to eachother in any software that requires you to specify the IP you're trying to connect.

The issue is, we cannot in any way shape or form, use this simulated network for LAN purposes, both of us have already:

  • Configured the metric on our adaptors
  • Turned off our firewalls
  • Turned on network discovery
  • Turned on the 'Function Discovery Resource Publication' service
  • Turned off any anti-virus software

If I run net view on cmd his PC does not show up, even tho I can clearly see him on the network browser

Print from network browser

On CMD, the only computer that shows up is my own.

My objective is to simulate LAN for gaming purposes, so we ca play together games that support that.

An example of the issue:

If I host something like a minecraft or a terraria server, he can't normally connect using my IP on our network, as expected. But when we try to play both Wacraft III and Civilization V we can't see eachother lobbies, which was our original purpose.

I'm going crazy over this issue, any help is appreciated.

  • Why do you expect LAN to work while connected to a VPN? You should be able to connect to a Minecraft or Terraria server with an IP address. – Ramhound Dec 2 '18 at 2:50
  • @Ramhound ZeroTier specifies in it's manual that it 'also has other features for establishing direct connectivity including LAN peer discovery', looking at some of the community talks it seems it should easily support LAN, even more because it simulates an Network adapter on my machine, I assumed windows should treat is as a regular Network. I'm in no way an expect in networks so I might be wrong tho, but to me it seems it should be the same as if we were side by side on the same modem. I expect it to be a windows configuration issue, that's why i'm seeking help here. – Matheus D. Lima Dec 2 '18 at 3:23
  • Do you remember if multicast and broadcast were enabled on the zerotier network config? – tladuke Jan 3 at 19:54
  • It seems to depend on the game, but it seems pretty common for games on windows to not have a way to choose which adapter to send broadcasts out of and windows will only use one adapter. There's a tool called WinIPBroadcast that helps in some case. – tladuke Jan 3 at 19:56
  • @tladuke I don't really, do you think that would have made it work? Radmin is a subpar solution for some games. But about WinIpBroadcast it shouldn't be necessary since i changed the metrics in order for windows to use the OpenVPN adaptor before any other one – Matheus D. Lima Jan 10 at 17:34
0

I managed to resolve the issue by changing VPN, for some reason ZeroTier wasn't able to work as a LAN for me, but when I changed to Radmin VPN and changed the metrics everything worked properly

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.