1

I bought a numeric keyboard to connect to my laptop to be easier for my to type numbers, but when i press the Num Lock button to enable writing numbers using this external keyboard it results turning some letters on my main keyboard to numbers. When i try to type this letter it types a number instead! .. I know i can press Num Lock again to type letters once again, but i hope there is a more faster way to keep my main keyboard typing letters only, and my external numeric keyboard to type numbers at the same type. My operating system is Windows 10.

So, is there a way to do that? enter image description here

1
  • What's your laptop model? Do both the internal and external NumLock keys control the number keys in both places?
    – fixer1234
    Dec 2 '18 at 7:33
1

Have you checked your BIOS for numpad activation on the laptop keyboard? Manufacturers often try to answer the absence of a numpad by setting a numpad on the keyboard, and a Num Lk trigger accessible via the Fn key. Depending on the manufacturer, you might have an option to disable the laptop keyboard integrated numeric pad via the BIOS.

1
  • I was able to disable the Num Lock default behavior from the BIOS as suggested, then both the Numeric keyboard and the letter keys of my default keyboard worked fine.
    – Brad
    Dec 8 '18 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.