0

I have a BU-353S4 USB GPS receiver. I am running Kubuntu 18.04. When I manually run gpsd with gpsd /dev/ttyUSB0, it correctly identifies the device and gets a fix when one is available.

When I let gpsd run automatically, this doesn't work. It seems that gpsd does not find the device and does not try to open it.

If I add /dev/ttyUSB0 to /etc/defaults/gpsd and I run the service, then the GPS works. However, if I then disconnect the GPS and reconnects it, then the daemon does not locate it again.

My /etc/defaults/gpsd says:

# Default settings for the gpsd init script and the hotplug wrapper.

# Start the gpsd daemon automatically at boot time
START_DAEMON="true"

# Use USB hotplugging to add new USB devices automatically to the daemon
USBAUTO="true"

# Devices gpsd should collect to at boot time.
# They need to be read/writeable, either by user gpsd or the group dialout.
DEVICES="/dev/ttyUSB0"

# Other options you want to pass to gpsd
GPSD_OPTIONS=""

What am I doing wrong?

  • Does a manual sudo gpsdctl add /dev/ttyUSB0 correctly add the device? – grawity Dec 4 '18 at 9:50
  • Yes. And also some text to make the comment long enough. – Shachar Shemesh Dec 4 '18 at 10:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.