I am currently playing a game which runs better on fullscreen, but the only resolution it supports in fullscreen is 640x480 and my display is 1920x1080.

If I set the scaling mode in the NVIDIA control panel to "aspect ratio," it upscales the game by a factor of 2.25, which makes the picture blurry. However, if I set it to "no scaling" the picture looks way too small even on my 32" display.

Is there a way to request integer scaling, preferrably without filtering?

  • Try setting your desktop resolution to 1280x960 (640x480 doubled) if you can and keep your the scaling mode to aspect ratio. This may stretch your screen horizontally, which you may be able to correct by changing the aspect ratio control to 4:3 on your monitor settings. – Blaelph Dec 6 at 1:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.