Has anyone else seen it where Windows 10 turns the display off after a short amount of time instead of the number of hours that you tell it to? I had set my computer at work to turn the displays (I have 2 monitors) off after 2 hours, but when I lock it out, they go off after only about a couple of minutes. I have even tried setting it to turn the displays off after 5 hours, but they still go off after only a small number of minutes after locking the computer out. I do have a screen saver set to run after 5 minutes of inactivity, but it's not the one that just blanks the screen, so I know it's not the screen saver kicking in. (And I don't see anything in the screen saver settings that says to blank the screen after so many minutes.)

Is there any fix for it, or do I have to forget the whole thing and just turn the monitors on and off when I go home and come back in? (This is very annoying.)

  • I have a feeling turning off while locked and turning off while unlocked are probably two different things. If the computer is locked, then what would the screen need to stay on for? Dec 4 '18 at 22:33
  • When the screen is locked, a different timeout applies—1 minute by default. D.Gmina’s answer tells you how to make it configurable.
    – Daniel B
    Dec 6 '18 at 9:34

Open the Run command, type regedit, and click OK to open the registry. Browse the following path: HKEYLOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\8EC4B3A5-6868-48c2-BE75-4F3044BE88A7 On the right side, double-click the Attributes DWORD. Change the value from 1 to 2. Click OK.

Use the Windows key + X keyboard shortcut to open the Power User menu and select Power Options. Click the Change plan settings link for the selected plan. Click the Change advanced power settings link. On Advanced settings, scroll down and expand the Display settings. You should now see the Console lock display off timeout option, double-click to expand. Change the default time of 1 minute to the time you want, in minutes. Click Apply. Click OK to complete the task.

  • Thanks. I'll see how it goes and then give the check mark if it works.
    – RobH
    Dec 10 '18 at 18:00
  • Ok, I've tried your solution, setting the time in that setting to 180 minutes (2.5 hours) and left the displays physically turned on overnight after locking out the computer, but when I got in to work in the morning, they were still on.
    – RobH
    Dec 11 '18 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.