2

I have a poweredgeT420 server and have been testing with qemu for virtualization.

I have been following some documentation and simply tried using the quick start guide from qemu quick start guide

After doing the command to boot a simple image I got the following error:

(process:23983): GLib-WARNING **: 21:58:30.131: gmem.c:489: custom memory allocation vtable not supported

(qemu-system-x86_64:23983): Gtk-WARNING **: 21:58:30.175: cannot open display:

I continued with other commands and tried creating an image

qemu-img create -f qcow2 testing-image.img 10G

then

qemu-system-x86_64 -m 2024 -boot d -enable-kvm -smp 3 -net nic -net user -hda testing-image.img -cdrom /mnt/FTP/AppZ/archlinux-2016.07.01-dual.iso

I again got the same error

Searching this on google did not lead me to any fruitful results, accept maybe some issues with older versions of qemu or possibly an issue with an incompatible processor.

VERSION="7 (Core)" 3.10.0-862.14.4.el7.x86_64 model name : Intel(R) Xeon(R) CPU E5-2403 0 @ 1.80GHz cpu cores : 4

Does anyone have any idea what I should be looking for to solve this problem?

2

This issue happens because of the glib2 bug (https://bugzilla.redhat.com/show_bug.cgi?id=1594304). Another side of this problem is that Red Hat and CentOS repositories contained an outdated version of QEMU (the recent is 4).

There is multiple solutions to this problem:

  1. Use qemu-kvm instead of qemu-system-x86_64

    https://www.tecmint.com/install-manage-virtual-machines-in-centos/

  2. Reinstall / Update all the QEMU packages from the fedora repo (https://copr-be.cloud.fedoraproject.org/results/fcomida/qemu-4/fedora-30-x86_64/00910942-qemu/)

    rpm -i /path/to/file/file_name.rpm

  3. Compile QEMU on your own (https://www.qemu.org/download/#source).

wget https://download.qemu.org/qemu-4.1.0-rc2.tar.xz
tar xvJf qemu-4.1.0-rc2.tar.xz
cd qemu-4.1.0-rc2
./configure

# Before running ```make``` checkout ./configure --help to get the list of available 
modules (usblib, smartcard, openGL support etc.) that you may want to add to your build. 

make
OR
make install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.