85

Screen elements are too small to click or read on my 4K laptop screen. How do I make it obey Gnome scaling, which is set to 200%?

I'm on Fedora 29, but this should be the same issue on Ubuntu 18.04 LTS

This issue also affects macbook retina display screens.

1
  • PSA: Using a scaleFactor >= 2 will for some reason make screen sharing buttons disappear (tested in Ubuntu 20.4.1, using ZOOM 5.4.6). Try using scaleFactor of 1.9 or 1.75 instead.
    – Hyperplane
    Dec 9, 2020 at 10:31

6 Answers 6

119

An answer that does not require changing common files that may be changed by future installs:

Zoom currently creates a file named zoomus.conf under your .config folder in the user's home folder.

One of the settings is ScaleFactor, set to 1 by default. Set this to 2, and next time you start the application it will have appropriate-sized visuals.

7
  • Thank you, you saved my time
    – id3vz
    Apr 25, 2020 at 3:08
  • 4
    Thank you! Here's the oneliner: perl -i -pe 's/scaleFactor=1/scaleFactor=2/' ~/.config/zoomus.conf
    – assafmo
    Jun 2, 2020 at 8:48
  • 4
    This worked for me too, though I was having the opposite problem. My external monitor was scaled correctly, but the built-in laptop screen it was at double the size, and very big. It was scaleFactor=auto and I changed it to scaleFactor=1 - thanks, very helpful!
    – david_nash
    Jul 4, 2020 at 4:38
  • 3
    It doesn't have to be full number, ScaleFactor=2 made the icons kind of blurry, but ScaleFactor=1.5 works great for me
    – Grzegorz
    Aug 14, 2020 at 15:18
  • 2
    autoscale=true worked for me, without changing scaleFactor
    – Reb.Cabin
    Dec 29, 2020 at 16:29
85

Recently I faced the opposite problem on Ubuntu 20.04 with Zoom 5.1.412382.0614: the UI was zoomed in and everything was too big.

The scaleFactor setting in the zoomus.conf file mentioned in the accepted answer was set to 1. However, changing the autoScale parameter to false solved the issue.

And as mentioned in the comments to this answer (thanks everyone!) it may be necessary to also set useSystemTheme=true so the autoScale parameter setting is respected.

11
  • 12
    what a piece of garbage that software is. But this worked for me on ubuntu 19.04 on the new update. Jun 18, 2020 at 14:06
  • 7
    Just had the same problem on Arch Linux distribution. Turning off autoScale worked for me too.
    – Lev K.
    Jun 19, 2020 at 14:32
  • 5
    Lifesaver! Thanks! Jun 20, 2020 at 16:03
  • 3
    thanks, some problem. In my case, it only did this on my 4k monitor (which is not hidpi). Moving the window to a small monitor scaled back to normal. So auto-scale is treating my 4k monitor as hidpi based purely on resolution, I think. I reported this to zoom. Jun 23, 2020 at 7:23
  • 4
    autoScale set to false but changed the scale factor to 2. Those two things in combination worked for me. Jun 23, 2020 at 23:09
26

The scale is set in an environment variable QT_DEVICE_PIXEL_RATIO.

You can add it to the desktop file in /usr/share/applications/Zoom.desktop by changing the Exec line to Exec=env QT_DEVICE_PIXEL_RATIO=2 /usr/bin/zoom %U

Or add export QT_DEVICE_PIXEL_RATIO=2 to you profile script

Source: zoom.us support

2
  • 7
    Since Qt 5.6 the variable name has changed to QT_SCALE_FACTOR, therefore: export QT_SCALE_FACTOR=2
    – dav.garcia
    Oct 22, 2019 at 8:34
  • 1
    Funny enough, this makes perfectly good working applications like Okular look terrible. Thus, I only added it to the .desktop file. Oct 30, 2019 at 14:07
4

In Fedora 31, installed from Flatpak, I edit ~/.local/share/applications/us.zoom.Zoom.desktop as Ray Foss suggested above.

Before:

Exec=/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=zoom --file-forwarding us.zoom.Zoom @@u %U @@

After:

Exec=env QT_SCALE_FACTOR=2 /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=zoom --file-forwarding us.zoom.Zoom @@u %U @@
3
  • 3
    Instead of modifying the .desktop, a flatpack override can be used: flatpak override --env=QT_SCALE_FACTOR=2 us.zoom.Zoom
    – jkoelker
    Jun 22, 2020 at 18:36
  • For pop users, path is ~/.local/share/flatpak/exports/share/applications/us.zoom.Zoom.desktop for Pop!_OS 20.04 Nov 24, 2020 at 15:21
  • This is exactly what worked for me, but (a) zoom flatpak is installed system-wide at /var/lib/flatpak/app/us.zoom.Zoom/current/active/export/share/applications/us.zoom.Zoom.desktop and (b) it scales too big on my 4k screen, i.e. QT_SCALE_FACTOR=0.5 is more appropriate.
    – aanno
    Jun 7, 2021 at 16:11
2

The other options did not directly work for me, however Luke Hsiao's tips [1] did.

With a Flatpack in Pop!_OS 20.04, I changed my ~/.local/share/flatpak/exports/share/applications/us.zoom.Zoom.desktop to include QT_SCREEN_SCALE_FACTORS env in the exec line. First I ran xrandr to find out my main screen is HDMI-A-0.

Then I prepended the env to the Exec line

Exec=env QT_SCREEN_SCALE_FACTORS=HDMI-A-0=2.00 /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=zoom --file-forwarding us.zoom.Zoom @@u %U @@

If you have more monitors you can append their settings as comma-separated values.

[1] https://luke.hsiao.dev/blog/zoom-scaling/

-1

Zoom can be started with a proper scaling by overriding the QT_SCALE_FACTOR environment variable.

$ QT_SCALE_FACTOR=2 zoom

https://wiki.archlinux.org/index.php/HiDPI#Zoom

Not the answer you're looking for? Browse other questions tagged or ask your own question.