I'm on Windows 10 Enterprise v1803 build 17134.441. Whenever I try to run any UWP app such as Photos or Calculator I get the error "This app has been blocked by your system administrator".

I am the admin on this PC and I've tried using "Run as Administrator" to no effect. I also tried editing group policies as some sites have suggested but it also doesn't change anything.

I also tried accessing AppLocker via secpol but when I go to Packaged App Rules -> Create New Rule when I get to the Publisher step where you can select an installed packaged app as a reference when I click Select I get an error related to SrpUxSnapIn.dll "MMC has detected an error in a snap-in and will unload it." and then secpol closes.

Here's the stack trace:

Exception type:
System.Reflection.TargetInvocationException

   at Microsoft.ManagementConsole.Internal.SnapInMessagePumpProxy.OnThreadException(Object sender, ThreadExceptionEventArgs e)
   at System.Windows.Forms.Application.ThreadContext.OnThreadException(Exception t)
   at System.Windows.Forms.Control.WndProcException(Exception e)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
   at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Form.ShowDialog(IWin32Window owner)
   at Microsoft.Security.Srp.Ux.SrpUxRuleListView.CreateManualRule(RuleType ruleType)
   at Microsoft.ManagementConsole.View.DoAction(Int32 actionId, Boolean selectionDependent, Int32 selectionId, IRequestStatus requestStatus)
   at Microsoft.ManagementConsole.View.ProcessRequest(Request request)
   at Microsoft.ManagementConsole.ViewMessageClient.ProcessRequest(Request request)
   at Microsoft.ManagementConsole.Internal.IMessageClient.ProcessRequest(Request request)
   at Microsoft.ManagementConsole.Executive.RequestStatus.BeginRequest(IMessageClient messageClient, RequestInfo requestInfo)
   at Microsoft.ManagementConsole.Executive.SnapInRequestOperation.ProcessRequest()
   at Microsoft.ManagementConsole.Executive.Operation.OnThreadTransfer(SimpleOperationCallback callback)

AppLocker

up vote 2 down vote accepted

You ran sfc /scannow and it detected errors that it couldn't manage to fix. These errors were described as "corrupt files", and even knowing which files they are, you have no means of fixing them yourself, since the problem here is with Windows protected files.

The way to fix the Windows files back to a correct state is to do Repair Install of Windows 10 with an In-place Upgrade. Follow well the steps described in this article.

This repair will be without losing anything, except all installed Windows Updates since Windows version 1803 was installed, and perhaps some settings.

Although this operation is supposed to preserve your data, applications, drivers and most Windows settings, I would still advice to take very good backups before starting, just in case.

  • Thanks for the assistance. Not sure I trust a repair install. Might as well reinstall windows fresh.. maybe Windows 7, Windows 10 is just a constant disaster. – Legion Dec 5 at 23:32
  • I don't recommend installing Windows 7, which is nowadays in effect unsupported. Windows 10 may have its faults, but it also has some good points, especially regular security updates. – harrymc Dec 6 at 7:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.