0

I fixed an issue for an open source project and am required to sign this CLA before the PR can be merged. A repository owner has approved the PR, but the CLA isn't showing as signed.

Details

I use Google Apps on my domain; it's an older, grandfathered version that is free, but hobbled. I sign in to my domain email with user@mydomain.tld, and my "Google account" is user@mydomain.tld.

However, my github email is gituser@mydomain.tld. git config --global --list initially had my email as gituser@mydomain.tld, so I have commits in the PR with my github email. I later enabled email privacy and updated my git config to reflect it with 1234+someuser@noreply.github.com (I've verified that my anonymized email is correct between my github profile and the git config).

I signed in and signed the CLA, but googlebot doesn't detect that the CLA has been signed, because user@mydomain.tld who signed the CLA (my Google Account email), didn't commit the code - gituser@mydomain.tld did (my GitHub email).

I tried to solve this by adding user@mydomain.tld to my github profile, verifying the email, and making user@mydomain.tld the primary email - then "updating the contact info" on the CLA. googlebot still doesn't accept the CLA as signed by the committing author.

I can't create a Google Account with gituser@mydomain.tld, because Google wants me to create a new Google account, i.e. a gmail account.

I can't add an alternate email to my existing Google Account, because my Google Account is hobbled as an old (free) Google Apps account that never upgraded to paid.


How can I sign the CLA, commit the code, and get googlebot to see the two as linked?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.