I use a VPS on port 7822. I can SSH login without any problems but when I use scp it gives me the following error after entering the password:

Unable to get term attr: Invalid argument

I ran the following command:

scp -P 7822 path/to/file login@ip:/tmp

If I run it with the verbose -v it says:

debug1: Authentication succeeded (password).
Authenticated to 68.66.241.13 ([68.66.241.13]:7822).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = de_AT.UTF-8
debug1: Sending command: scp -v -t /tmp
Unable to get term attr: Invalid argument
debug1: client_input_channel_req: channel 0 rtype keepalive@openssh.com reply 1

and it repeats the last line infinitely.

Thanks for your help!

  • 1
    Does the remote system print anything when you ssh in? Try ssh -p 7822 login@ip:/tmp true (which'll run the true command on the remote system, then exit) -- if that prints anything other than the password prompt, that may be the problem. – Gordon Davisson Dec 6 at 21:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.