When i'm trying to run anything from the MMC or any MSC related apps in my local account (An Administrator), all i get is an error : The application was unable to start correctly (0xc0000102)., and if i do try running mmc.exe, all i get is a Blank MMC, and the taskbar name "Console1". But if i do try running it thru an elevated CMD, i can start them fine (Example: compmgmt.msc). I have tried running SFC, DISM, and chkdsk /f /r, but they all do return a "normal" answer (all is fine).

Steps Reproduced:

  1. SFC/ SCANNOW: no integrity violations

  2. DISM: all is good

  3. chkdsk/f /r - initially what caused the problems in MMC, and other areas of the laptop. I ran a chkdsk command from my laptop when it suddenly caused a bootloop. (Stuck in Preparing Startup Repair)

  4. regsvr32 msxml.dll/msxml2.dll.msxml3.dll: msxml and msxml2 not found in sys32 folder. only msxml3.

Workarounds: 1. Start .msc's from Elevated CMD

Other related Problems Found:

  1. Missing MSXML and MSXML2. (but sfc and dism still does not recognize these problems)

Is there any fix to these problems? Aside from a full reset (a last resort)?

  • Do they work correctly for other user accounts? How about from yours, only in Safe Mode? If you were having disk errors, then a reset is probably your best bet (after ensuring the disk is OK and/or replaced), as based on what's here, it sounds like it's a permissions problem (possibly ACL corruption caused by disk errors), and those are usually REALLY hard to find (to correct). – Ƭᴇcʜιᴇ007 Dec 6 at 17:52
  • It sounds like the application is not having access to some resource. Could it be that you installed a new .NET Framework? Maybe some files changed ownership – dmb Dec 6 at 18:42
  • Or have you uninstalled the .NET Framework? – harrymc Dec 6 at 20:55
  • as an addition to the launching of administrative tools on an elevated cmd, they will also work in their normal way of launching (Win+X; Searching the tools) IF i turn off UAC – Ivan Aldwin A. Cristobal Dec 7 at 5:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.