I have an ASRock b450M with AMD Ryzen CPU and a Trident-Z. I tried to mount a different DIMM but something went wrong. I powered on the motherboard but the cpu fan just run for half second and then nothing happened. I got same results 3 o 4 time. At some point the cpu fan started running but the system entered in the bios. Mouse and keybord did not work and I noticed that there wasn't power from the usb. So I was stuck in the main page of the bios. Therefore I tried to mount back the old DIMM. However I get same results. The motherbord powers on but I get in the bios main page and the usb ports do not work. The main page tell me that the system properly recognize the hardware. I have cleared the cmos but no results. I cannot understand how it's possible.

Someone have any solutions?

  • Did you double check all the connections on the motherboard (cards and cables) and make sure one of them didn't come loose while you were replacing the RAM. – HazardousGlitch Dec 6 at 18:24
  • 1
  • 1
    @Hannu what it means? – Emanuele Vannacci Dec 6 at 18:31
  • @HazardousGlitch yes, I checked but everything is ok – Emanuele Vannacci Dec 6 at 18:32
  • Hi, can you get a hold of a PS/2 keyboard or adapter? Is your keyboard mechanical? It seems the system do POST as it's going into the BIOS/UEFI as stated in the manual. – dmb Dec 6 at 18:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.