I have setup a SSH server on windows using freeSSHD.

From Linux machine I run the following command to SSH to Windows:

SSH -i mykey myuser@mymachine

The moment I hit the enter button, I no longer can type anything in the terminal as all the text in the terminal disarranged, but I can see it was successfully connected to the windows server.

  • I presume this is a problem? (you might want to reword the question)... Have you checked the Windows box for a popup dialog / error message? What does ^D do? – Attie Dec 6 at 23:58
  • Have you tried the official forums for that product? You can make a bug report there: freesshd.com/index.php?ctt=forum – HackSlash Dec 7 at 0:01
  • 1
    It's difficult to answer this question without seeing how the text is "disarranged" - it may be as simple as the Windows end-of-line sequence vs. the Linux end-of-line sequence, or a mismatching TERM type, or something completely different. – dirkt Dec 7 at 12:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.