2

I'm trying to install windows 10 on a new 1TB SSD I got. fresh install, new drive, new laptop. Dell Inspiron 13 5000. Setup for UEFI. Created a bootable USB using rufus (GPT for UEFI (non CSM)). I get into setup no problem. I delete all the partitions and use diskpart to setup the drive for GPT.

I select the unallocated partition to install to. Windows created the additional partitions that it needs and then it starts the install process. Immediately, it errors with

"windows could not prepare the computer to boot into the next phase of installation"

Spent hours googling with no luck. I haven't been able to find a log file to look at.

What can I try to determine what the problem is?

No other drives installed. legacy mode disabled. Secure boot is off. PTT is off.

5
  • Is UEFI set to use AHCI? – harrymc Dec 8 '18 at 18:46
  • @harrymc there isn't an option for that – DustinDavis Dec 9 '18 at 0:56
  • There must be and option for IDE/AHCI. – harrymc Dec 9 '18 at 7:53
  • @harrymc either way, windows created the partitions and it writes files but the copy process fails. So what would IDE/AHCI change? I'm guessing it's failing during the write of the boot sectors, but I turned off the security and all that. – DustinDavis Dec 10 '18 at 16:32
  • 1
    AHCI works better with GPT than IDE, which is why I suggested it. This might or might not be part of the problem. – harrymc Dec 10 '18 at 16:36
5

I also created a bootable USB to install Windows 10 on a fresh system (as I only had a Mac, I used this great guide), which is also based on a GPT partition table on the USB stick. I ended up with the same error message and was stuck for hours with it.

EricDAltman's answer and the others finally pointed me to the problem and the solution: The windows installer (yes, in 2020! and UEFI is not really new anymore - and all this while using the latest Windows 10 october 2020 iso) get's into trouble with a GPT formatted USB stick and presents the message "windows could not prepare the computer to boot into the next phase of installation". The USB stick's GPT somehow interferes with our HDD/SSD where we wanted to install Windows 10 (this is also why geg's solution also worked, since he copied all the installation files to the HDD and unmounted the USB stick which caused the windows installer to work again).

The solution is to simply format the USB stick using MBR partition table instead of GPT - so for me doing this on a Mac first:

diskutil eraseDisk MS-DOS "WIN10" MBR /dev/disk2

And NOT diskutil eraseDisk MS-DOS "WIN10" GPT /dev/disk2 (I guess with other tools like rufus it's simply a configuration option there also).

3
  • After trying just about every other possible solution, this is the only thing that fixed it for me; thank you – Melllvar Dec 28 '20 at 0:00
  • I had followed the same guide and formatting the USB stick using MBR instead of GPT solved the issue for me as well. Thank you! – MWLindenbach Jan 20 at 17:13
  • I F*&^% LOVE YOU. – dutzi Apr 29 at 20:20
2

In my experience, this has been caused by one of two issues. First I'll offer solutions to a potentially broken installer (which I've experienced a few times over the years). Then I'll comment on the Installation Media's format at the end.

One possibility is a bug in the Disk Partitioning by the Windows installer, in my experience. Over the years I've seen it either utilize the wrong sector sizes or, more commonly, not set the boot partition as active. This is assuming that the failure occurs AFTER the partitions are setup which has been my experience.

To repair this, after Windows Installer sets up the partitions and fails to install, please try the following:

1) Boot with your Install drive mounted and go to the "Repair Options" section 2) Open a Command Line 3) Then type "diskpart" 4) Verify you only have the one drive by typing "list disk" 5) Type "select disk #" with # being the disk you're installing to 6) Then "list part" which will give you a list of partitions on that disk you have selected 7) Type "select part #" where # is the boot partition that the installer created but failed to install to 8) Type "active" to make that the active boot partition for this device 9) Type "exit" to finish with diskpart and let it save the changes

At this point you should be good to reboot and attempt the install again.

If at this point you're still out of luck, it is likely the installation media you are using. Since you are using a GPT USB drive, it could be conflicting with the installer's attempt to locate proper installation destinations (even with you explicitly stating yours). To remedy this, format the drive as MSDOS (good ol' FAT32) instead of GPT and try again.

2
  • You can't mark the partition as active, that's for MBR only. I tried already. If I don't format the USB media as GPT, it won't boot to it. – DustinDavis Dec 7 '18 at 1:28
  • My apologies. Yeah, I did write that a little linearly then went back to adjust the beginning of the answer afterwards so my thoughts were mostly focused on the format of the USB. I've never formatted the USB as GPT before. When you use RUFUS to copy to the USB drive, what settings are auto-populated after selecting the ISO? A screenshot would help. – EricDAltman Dec 7 '18 at 18:49
0

This solved it for me. The issue was caused by installing from USB.

  1. Create a partition on your SSD/HDD, formatted for GPT and fat32
  2. Assign a letter to it. (I used D: because I think I read about install issues due to using C:)
  3. Copy the windows installation files from your USB to the new HDD/SSD partition
  4. Shut down, remove USB
  5. Boot from your SSD/HDD partition and install on the remainder of the unclaimed disk
  6. Install Windows
  7. Wipe the boot partition if you want to reclaim that space
0

Adding my solution to my specific problem in case somebody else has the same issue:

  • my PC could only boot from a GPT (not MBR) formatted USB drive
  • the partitioning would fail with either:
    • "couldn't create a new partition or locate an existing One" which can be fixed using diskpart, clean, convert gpt, but then you'd get:
    • "windows is unable to the selected location. Error:0x80300001"

After trying all the solutions presented online (including using different USB ports, USB 2.0 drives etc.) I simply:

  • start installation using a GPT formatted USB installation drive.
  • swap it out for an MBR formatted drive at the partitioning step (not before)

I assume the 2 GPT drives (USB and internal HDD) were somehow conflicting and the installation failed. Setting active and assign letter=c on the internal hdd did nothing.

This is obviously a hacky solution, but it worked. HTH.

1
  • I can't believe this works ^^ – Manuel Araoz Mar 24 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.