I'm using Fedora 29. I had to reinstall it, but I kept a backup of all my folders. After the installation, I booted up in Ubuntu (dual boot) and copied and replaced all the backup files (including the etc folder, and usr, etc). I then booted from Fedora 29 and I get this error:

enter image description here

I tried to boot in rescue mode and I get the same thing:

enter image description here

I googled it, but couldn't find anything helpful.

  • 1
    But why did you copy the old /usr and /etc? That almost completely defeats the point of reinstalling the OS, it's like reinstalling Windows and then copying the old C:\Windows on top of it. – grawity Dec 7 at 6:03
  • Looking in /etc for different files between the backup and a fresh install might spot the odd config file you want to keep... – Xen2050 Dec 7 at 8:26
  • Yes, It does defeat the purpose of a new install...almost. I had to re-install because I had disk encryption, complex issue, but the re-installation fixed it. I copied all the files, not just the etc and usr. I did this so as not to have to reconfigure and re-install everything. Replying to your second comment, I'm not that good yet, so I don't know what got changed and what didn't, so I just copied everything. – Dash Conroy Dec 8 at 8:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.