My Windows 10 desktop is not able to update its system clock from internet time servers. At least, I don't think it can...although the time it's displaying seems roughly accurate (within a few minutes).

The reason I say I don't think it can is because when I drill down into the Internet Time Settings dialog and click Update Now, it always returns with a message complaining that a timeout error occurred...but the message also includes "The clock was most recently synchronized at ..." with the time at which I hit Update Now displayed.

This same error occurs regardless of which time server I try. I've tried time.windows.com, time.nist.gov, and several that I looked up at https://tf.nist.gov/tf-cgi/servers.cgi.

I thought I might have a firewall problem, but the system clock on my Raspberry Pi running stretch, which is on the same LAN behind the same Cisco firewall, seems to be fine. It's set to be synchronized against NTP.

Suggestions as to how to fix the Windows internet time problem?

  • Your computer internal clock may be running incorrectly if the CMOS battery is dying. – harrymc Dec 7 at 11:54
  • The CMOS clock seems to be okay (it was only off by a minute or so). While I guess the battery could still be dying, the system is only 18 months old and nothing else is behaving oddly. Any other thoughts about what might be going wrong? – Mark Olbert Dec 7 at 15:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.