2

I am subscriber for Office 365, my Windows is set up in 'en-US' but my native language is German. So I installed Office in 'de-DE' as well.

Now everytime I want to write an e-mail or Word document in German, it says that's everything is wrong. So I mark everything and change the proofing language to German (yes I unchecked the automatic detection). I type a single character and it switches back to "English". I even tried setting it as default language. Actually when I choose "German (Germany)" and type anything it switches to "English (Germany)". Even if I delete something, it never turns back. Like it's truly temporary.

Whatever I do, Word just doesn't stick with another language. I honestly ask myself for what I am paying so much if this feature from Office 97 is not even working...

Any clue what causes this weird behavior? I'm completely out of ideas.

EDIT: As by request I have the following settings:

  • Display Language: German (de-DE)
  • Installed Languages: German (de-DE), English (en-US)
  • Settings: Primary Proofing Language is German, I even removed English from the list
3
  • How did you try switching the proofing language? Does this issue happen within non-Office editors, such as Notepad? Have you tried reinstalling the language pack? – Steve Fan Dec 10 '18 at 8:37
  • @SteveFan No of course not. It's an office related issue, but occurs through Outlook and Word. No, not yet. I never installed on anyway. But I will try this when I'm home from work. Ramhound I added the information I know out of my head, if you require any more info I'll update it later. – SharpShade Dec 12 '18 at 9:00
  • Having a different language for your system is problematic. See answers.microsoft.com/en-us/msoffice/forum/…. – Charles Kenyon Jul 26 at 13:19
3

Please make sure that you have the languages installed not only in the Office, but also in Windows Settings (Win key + i) > Time & Language > Language.

After opening a new e-mail window, place the cursor in the text field and make sure to select the correct typing language by pressing Alt+Shift or using the language selection menu near the clock in the Windows taskbar. Or by pressing Review > Language > Set Proofing Language... (without selecting any text). Then start typing and it should work.

I have explained the issue and solution in greater detail here: https://superuser.com/a/1442448/212626

2

Not the answer you're looking for? Browse other questions tagged or ask your own question.