-1

This question already has an answer here:

For some background, I'm on Windows 10 however with the files I'm going to talk about I've used them in shared folders with Ubuntu VMs before.

In a folder on my machine, there is a file named '...' I really don't know where this file came from. It was inside a directory which contained one of my programming projects, in which I was using git. However, I cannot delete this file in any means I've tried so far. When attempting a simple right-click + delete, I get the message: "Error 0x80070091 The directory is not empty."

When I attempt to delete from powershell using del or rm, I get the message: "When attempting to del : An object at the specified path C:\Users\mdmil\Concurrency\... does not exist."

I cannot rename the file by any means. When I try to rename from powershell, I get the same aforementioned error. When I try to rename from file explorer, I get a "this file is open in another program" error.

I even got desparate enough to try to share the folder with a Linux VM, and attempt to delete the file via the inode number to no avail.

When I attempt to open the file in notepad++, no file opens. I presume it is because it is trying to interpret it as a directory due to the ... naming.

I'm currently at a loss as to how to fix this. Any help would be appreciated!

marked as duplicate by Twisty Impersonator, Run5k, Dave M, Community Dec 10 '18 at 19:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

If you go to the directory where the ... file is, then type:

type dir /x

you should see the file and its 8.3 name, eg:-

 Directory of C:\Users\CurrentUser\Temp

09/12/2018  23:09    <DIR>                       .
09/12/2018  23:09    <DIR>                       ..
09/12/2018  23:09                 0 A535~1       ...

You can now use this 8.3 name to delete it, eg:

del A535~1
  • 3
    AFH, I am out-of-town and utilizing my phone right now, but I am rather certain that this question (and your proposed answer) have been posted in a prominent Super User Q&A previously. You are one of our community’s very best contributors, so perhaps you can point the OP in that direction. Thanks for your help! – Run5k Dec 9 '18 at 23:40
  • @Run5k - I searched and found this 9-year-old answer, which is the same as mine, though it's not the accepted answer, and there weren't a lot of votes for either the question (7) or the answer (2) - I've not found anything more prominent. The question is related, but not quite the same, so I don't know if it qualifies as a duplicate. – AFH Dec 10 '18 at 13:47
  • Thanks for the feedback. I made it back to my hotel late last night and found two Super User questions within my list of Favorites that should qualify as duplicates. I posted them under the question accordingly. – Run5k Dec 10 '18 at 13:54
  • I've checked your links, and the `\\?` prefix also works, making it a very good alternative solution. I think readers should be aware of both solutions, as there may be certain circumstances when only one of them works. – AFH Dec 10 '18 at 14:17
  • From my perspective, the bottom line is as follows: this question is essentially the same problem, and this subsequent answer is the equivalent of yours. You really can't have too many good options within the Super User realm, but I hate to see a brand-new contributor (like the OP) creating what is essentially a duplicate of a Q&A with over 2000 views, an accepted answer, and numerous up-votes. – Run5k Dec 10 '18 at 14:53
0

I found a fix to the issue. It's not a great solution, but it worked. I opened git bash to that folder, use "rm -rf ..." and that deleted the file in question. Still haven't figured out how to fix it with native Windows tools.

  • If you type dir /x in the directory where the ... file is, then you should see its 8.3 name, and you should be able to use this to delete it. I can't create this file, so I can't be completely sure that this works. – AFH Dec 9 '18 at 23:04
  • I have used bash to create ... and can verify that the method works, so I have submitted an answer for the benefit of others, especially those who don't have bash. – AFH Dec 9 '18 at 23:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.