0

I'm afraid I heavily messed up a laptop (Dell Latitude E5570, running Windows 7 Professional).


Update: I found a way to start Windows … somehow. I'm not sure if running "Startup Repair" from a Win7 disc several times made this possible, if it is due to the steps recommended in the existing answer or if this would have worked from the start, but anyway:

  • I enabled UEFI and disabled Secure Boot.
  • I still cannot add any boot options (see screenshot at the very bottom), so when I start the computer, I just get a black screen stating that no bootable devices have been found.

  • However, if I hit F12 while booting, the "one time boot options" dialog opens, where I can choose to boot from CD/DVD.

  • After selecting CD/DVD, I'm prompted to "press any key to boot from CD/DVD". Then: Not pressing any key successfully starts Windows (from the hard disk!).

Still, I'm looking for a fix – but in the meantime, this is at least a functional workaround.


Background: Initially, I suspected an issue with the laptop's RAM due to some spontaneous BSODs. In order to test the RAM, I created a bootable USB stick with Memtest86 and tried to boot from the stick. However, the laptop kept booting the installed Windows 7 instead of booting from the stick, although I set the boot sequence to start from the stick first. Enabling UEFI or the "legacy mode" didn't change anything, nor using the latest vs. the old version of MemTest86.


At this point, I probably started to screw things up: I deleted the UEFI boot options and enabled the legacy mode. After the system insisted that it could not boot from the stick, I gave up on MemTest and wanted to return to the previous boot settings. To this end, I selected "Restore BIOS defaults" and rebooted.

However, Windows didn't startup anymore. Unfortunately, I didn't take notes of all the error messages and steps I took – because I didn't expect this to be such a big deal. Most of the time Windows complained that it could not startup. I also received some error messages that the boot manager could not be found or that "an operating system could not be found". Sometimes Windows tried to start but died with a bluescreen.

To fix the issue, I started from a windows installation CD. As the automatic "Startup Repair" could not solve the problem, I tried my luck with the command line.


Many online resources recommend to use diskpart and I tried selecting different partitions or volumes (select partition #no and select volume #no; active), but I'm afraid by not really knowing what I was doing I probably made things worse.

I also tried

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

However, the last command reported that no OS could be found.

Following instructions here I ran

attrib c:\boot\bcd -h -r -s
ren c:\boot\bcd bcd.old
bootrec /rebuildbcd

This did find 1 Windows installation, which I added to the boot list. (Interestingly, running bootrec /rebuildbcd again finds no installation!) Still, Windows doesn't boot. Running bootsect /nt60 SYS /force after a "successful" bootrec /rebuildbcd didn't help either.

Following these instructions I ran bcdboot C:\Windows /S C:, also with no success.

I also tried bcdboot C:\windows /s Z: /f UEFI, following this tutorial. (Not having any "ESP" volume, I might have selected the wrong source volume, making things even worse …)

In-between, I tried running the "Startup Repair" many times, hoping that my efforts brought the system at least into a state from which the startup repair might recover. However, this always reports that the issue cannot be solved.

Below screenshots from the current "status" (sorry, they're in German). If I try to boot, Windows complains "Error: Windows failed to start. A recent hardware or software change might have caused the issue".

Output of diskpart: diskpart output

Using bootrec: (Note that the first rebuildbcd fails, the second finds 1 installation. Running it a third time again finds 0 installations.) bootrec

Boot Settings. Strangely, I cannot add any UEFI boot options anymore, so I must select "Legacy": Boot Settings

I know that some very unwise steps brought me here. I'm also aware, that this is a quite longish question, but I hope it is sufficiently clear.

I'm stuck and grateful for any advice. What is wrong with the startup process and how can I fix it?

1

I was able to find this guide specifically from Dell that does have slightly different commands from what you've been running so far. The EPS partition you mention missing should just be the EFI partition, but if that's gone you're probably headed to a reinstall. Best of luck.

  • Thank you for your reply! Lacking an partition labeled "EPS" I used "volume 1" (see screenshot above). This allowed me to change to \EFI\Microsoft\Boot` (so apparently this is the correct volume) and run bootrec /fixboot` there. For the last bcdboot command I had to add a /f flag to avoid a syntax error complaining about the "All". This succeeded, although with a warning that some files might be missing (see here). Bottom line: no effect … – CL. Dec 10 '18 at 16:57
  • I noticed that the recovery DVD is named Windows8_1_x64 but you said the installation is Windows 7. If the install DVD is a different OS that might be causing the error because it wouldn't have the right files to match. I'm not 100% sure on that though. – LostWander Dec 10 '18 at 22:08
  • I thought (hoped) the disc version should not matter because the disc just provides the tools to work with the files on the hard disk. But maybe you're right - I'll try to get a Windows 7 disk tomorrow (didn't have access to one today). – CL. Dec 10 '18 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.