I am in the process of upgrading a Debian installation to version 9 and I am facing problems getting nginx with passenger to run. The issue is with trying to install
libnginx-mod-http-passenger, specifically, it seems to require a lower version of nginx than comes from the standard debian repositories:
# sudo apt-get install -y libnginx-mod-http-passenger Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libnginx-mod-http-passenger : Depends: nginx-common (< 1.10.4) but 1.14.2-1~dotdeb+8.1 is to be installed E: Unable to correct problems, you have held broken packages.
My passenger source list looks like this:
# cat /etc/apt/sources.list.d/passenger.list deb https://oss-binaries.phusionpassenger.com/apt/passenger stretch main
I explicitly want to install from repos. So, how can I get past this issue?