1

I have a program (QGIS, which uses QT5) that will not come to the foreground. It starts maximized (that's fine) but it stays behind all my other programs. It can be focused, and I can work in QGIS, but any non-minimized programs stay in front of it.

I have tried the AutoHotKey script suggested in an answer in this post: Program windows won't come to foreground when selected in Windows 8.1 but it didn't help.

  • You may during the window's creation add the Qt flag of WindowStaysOnTopHint. – harrymc Dec 11 '18 at 14:17
  • Is that a command line flag? Also, this is new behavior, this program worked just fine up until a few weeks ago. Uninstalling / reinstalling has not helped. – HeyOverThere Dec 11 '18 at 21:18
  • No, the program has to be modified to add the flag. – harrymc Dec 11 '18 at 21:24
  • I'd rather not re-compile the program, and I don't think it a problem with the program itself, it works just fine on other machines. I think something has gone sideways with my Windows profile. I'm trying to find a solution that doesn't involve wiping and starting a new profile. – HeyOverThere Dec 11 '18 at 21:27
  • You may try a new profile. – harrymc Dec 11 '18 at 21:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.