1

I have very basic knowledge on networking. I recently purchased a Dell server to do my own development work. I have installed a RedHat Linux server. I am trying to set up a local server client set up.

Here is what I did.

  1. Connected the server and client computers to a router
  2. Assigned a static IP to ethernet2
  3. Opened port 22 as below

    firewall-cmd --zone=public --add-port=22/tcp --permanent
    firewall-cmd --reload
    

Now I am trying to connect to this server through Putty from a Windows client machine. But I am getting a

connection timed out

error. What I am missing? Can someone help me to set it up?
I've never used RedHat before.

  • You didn't mention whether ssh has been enabled on your Red Hat machine. Run systemctl enable sshd and systemctl start sshd – n8te Dec 11 '18 at 5:42
0

By default, redhat 7 comes with firewalld enabled with the ssh service configured in the public zone, which means you can connect through ssh without further configuration

Here are some things you can check:

  1. Verify both server and the client are in the same network and they can ping each other.
  2. If you thing it's a firewall related issue you can flush all rules with the following command and test again:

    iptables -F

  3. Provide more information to see if we can help (IP addresses, routing table, firewall rules, etc.).

Waiting for your feedback.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.