0

I am using TB 60.0 from PortableApps under Win 10. I have configured a gmail account 4 months ago, and it worked fine.

Now after 4 months I open TB, and I have a connection failure, as a notification in the systray

enter image description here

and a popup with

enter image description here

In an Ubuntu box, I could use TB 52 to read emails from that account with no problem, without needing any further configuration of the gmail account. The "failed" popup window seems to be what in Ubuntu prompted me to enter my gmail password.

How can I solve this?

Is that related to any certificate that I should get and import?

I found very scarce information, which did not help.

Something perhaps related: I am using a corporate PC, and a short while ago, I had issues with Firefox.

0

You need to toggle the secure apps setting on your Gmail account. There's a thread about it on the Mozilla support pages, and a discussion on it here https://support.mozilla.org/en-US/questions/1201406

  • Although this is a solution, its not the only one and not the best one either. This used to be the only one though. – LPChip Dec 11 '18 at 8:29
  • Ah, ok. It's a while since I used TB, I just tend to use the 'phone app now for Gmail. – spikey_richie Dec 11 '18 at 8:30
  • It doesn't seem to be a matter of configuring my gmail account. Please see updated OP. Would you still think I need to configure the account in a web browser? – sancho.s Dec 13 '18 at 4:34
  • @sancho.s because that is how gmail works. If you google your problem, it are these solutions that you find and if you then try them, you find out that they actually work. – LPChip Dec 13 '18 at 7:52
0

New answer based on additional information

The error you receive tells you what the problem is.

Somehow on your system, the authority that issued the gmail security certificate has been marked as untrusted. As a result, the SSH connection cannot be established and thus, your email doesn't work. It is likely a block set at a corporate level. You need to contact your network administrator.

Old answer based on incomplete question

Somehow Gmail marked your device as insecure, and that is why you cannot connect anymore.

If you login to gmail, it will most likely give you a message at the top that a connection attempt was blocked, which you can click to unblock it and from that moment on, the email is most likely working again.

That said, it is recommended to create a secure app password, and use that instead. You can do this from your Google Account Settings. Alternatively it is possible to reconfigure your thunderbird's Google account and directly setup an App connection. You will get a popup in Thunderbird where you are asked if Thunderbird can have permission to use Google. Once you say yes, your account is configured.

You do need to remove the old google account first though, but don't worry. Since it is IMAP, you don't loose anything.

  • I didn't see the message you mention. It doesn't seem to be a matter of configuring my gmail account. Please see updated OP. Would you still think I need to configure the account in a web browser? – sancho.s Dec 13 '18 at 4:35
  • I did not have two-step authentication, so that was not the problem. Now I have enabled it, and I created the app password. I re-created the account, and I still get the same popup window with error. – sancho.s Dec 13 '18 at 5:05
  • @sancho.s because that is how gmail works. If you google your problem, it are these solutions that you find and if you then try them, you find out that they actually work. – LPChip Dec 13 '18 at 7:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.