9

I am having an odd issue with Windows 10 and it seems to have started about a month ago. When opening an application, I usually just click in the Cortana search bar and type a few letters of the application I am wanting and Cortana usually finds the application I want, like in this image:

Cortana finding Word

As you can see, just by typing "wo", it found the "Word 2016" application, just like I wanted.

For some reason though, it can't find 85% of my other applications. Here's an example of me trying to load up Excel:

Cortana trying to find Excel

As you can see, Cortana is just not finding the desktop application. It is in my start menu though (just like Word 2016 is):

Excel in my start menu

So I am trying to figure out why some applications Cortana finds and other's it does not. Cortana used to find all my applications 100% of the time until about a month ago or so. I did try reindexing, per a Google search I found, but it did not help. Any help on this would be appreciated.

4
  • I can search all installed desktop application and store application except some installed foreign name applications. So it should be your system problem. Try to register Cortana to check with the command line in link tenforums.com/tutorials/… – Joy Dec 12 '18 at 8:51
  • This has been a problem since at least Windows 7. – Hashim Aziz Dec 13 '18 at 22:54
  • Is there a shortcut for these programs in "C:\ProgramData\Microsoft\Windows\Start Menu\Programs"? The only way my search finds a program is if there is a shortcut for the program in there. – Eric W. Dec 16 '18 at 13:04
  • What about trying to sfc /scannow as an admin in the CMD? It may help. – Jesús Hagiwara Dec 20 '18 at 13:18
2
+50

There are two solutions I can think of:

  1. Easy Method:
    If there are just a few applications you want to ensure showing up

    • Go to %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs

    • Add a shortcut to the .exe of these applications.

  2. Advanced Method:

    • Re-index your search by going to "Control Panel" → "Indexing Options" → "Advanced" (requires admin) → "Rebuild Index".
    • You can also modify the indexing options to include folders that are not currently in scope, as this may affect you if you have separate/partitioned drives, etc.
4
  • 1
    Neither of these solutions work for me. For solution #1, I have shortcuts in there, but it's not finding those. And for solution #2, in my question, I stated that I already tried to re-index. It did not help. My start menu is already an included folder and I rebuilt the index, but that did not fix the issue. – Icemanind Dec 14 '18 at 0:33
  • You can try: superuser.com/a/947415/972878 – Jonathan Laberge Dec 14 '18 at 1:45
  • I just tried this. Did not work for me. I also deleted and rebuilt my index again, after deleting that registry key. Still no good. – Icemanind Dec 14 '18 at 3:18
  • Have you tried running a system file check scan? sfc /scannow Only other solution is probably a complete re-install of OS. – Jonathan Laberge Dec 14 '18 at 19:15
2

None of the solutions found on the internet worked for me (and I've googled for hours), but @harrymc's answer lead me on the right track, so let me expand on it.

In my case, the problem was in Cortana's settings store getting corrupted. Cortana is not just the assistant, but Windows search is integrated with it and you need to reset its data and related settings.

  • The first step is completely resetting what's being indexed by Windows - delete this registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\CrawlScopeManager\Windows\SystemIndex (taking its ownership is required). Sign out and sign in back again or reboot.

  • Next up is resetting Cortana. Go to task manager, right click on Windows Explorer and select End Task. The taskbar should be gone. Do the same with Cortana. This unlocks its files.

  • Open a PowerShell window via file > run new task, enter powershell and check Create this task with administrative privileges

  • Run Remove-Item "$Env:USERPROFILE\AppData\Local\Packages\Microsoft.Windows.Cortana_cw5n1h2txyewy" -Recurse -Force. This removes stale search data.

  • Run Get-AppXPackage -AllUsers -name "*cortana*" | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}. This reinitializes Cortana and search for your user profile.

  • Run explorer via task manager, this time without admin privileges, wait a bit for the search index to be rebuilt and Windows Search should be working again.

As a last resort, if this didn't work for you, you can create a new Windows user. The new user should have a working search and you can migrate your data there.

1

There are so many problems with Cortana and Windows Search, that it's worthwhile looking into third-party replacements like Open Shell Menu (Classic Shell), Everything and Agent Ransack.

Below is a collection of all the workarounds I could find, but more probably exist.

  • Ensure Windows 10 is fully updated.

  • Running Control Panel > Troubleshooter > View All > Search and Indexing or download and run the Windows Search Troubleshooter.

  • Re-install Cortana using elevated PowerShell:

    Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    
  • Reinstall all apps using elevated PowerShell:

    Get-AppxPackage | Remove-AppxPackage
    Get-AppxPackage -allusers | foreach {Add-AppxPackage -register "$($_.InstallLocation)\appxmanifest.xml" -DisableDevelopmentMode}
    
  • Re-register all apps using elevated PowerShell:

    Get-AppxPackage -allusers | foreach {Add-AppxPackage -register "$($_.InstallLocation)\appxmanifest.xml" -DisableDevelopmentMode}
    
  • Repair the missing applications (if only a few), using:
    Settings > Apps > Apps & features > select app > Advanced options link > Repair.

  • Repair all applications using elevated PowerShell:

    reg delete "HKCU\Software\Microsoft\Windows NT\CurrentVersion\TileDataModel\Migration\TileStore" /va /f
    get-appxpackage -packageType bundle |% {add-appxpackage -register -disabledevelopmentmode ($_.installlocation + "\appxmetadata\appxbundlemanifest.xml")}
    $bundlefamilies = (get-appxpackage -packagetype Bundle).packagefamilyname
    get-appxpackage -packagetype main |? {-not ($bundlefamilies -contains $_.packagefamilyname)} |% {add-appxpackage -register -disabledevelopmentmode ($_.installlocation + "\appxmanifest.xml")}
    
  • Perform a system scan in an elevated Command Prompt:

    sfc /scannow
    
  • Create and use another user account.

  • Reset Windows 10.

1

After trying all the suggestions on here, nothing seemed to work. But apparently, the issue has fixed itself. I don't know if it was a Windows Update that did it or what happened, but the issue is resolved and my search is working again. I did have updates that came through recently, so I can only assume one of those updates resolved. Recently KB4476976 came through and it seems to work after installing that, although, I didn't see anything specific in the KB notes that seemed to address the issue. Anyway, thanks for everyone's suggestions!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.