3

I have the same problem as asked here How to access *remote* usb devices over rdesktop and here Remote desktop: remote USB devices not recognized long time ago, unanswered.

I have a remote machine with Windows 10 and an USB device plugged in there. When I go there physically, log into it, I can see the USB device. When I log into that machine remotely with RDP, the device is not visible/accessible. Like it was not there at all.

How can I access remote USB device of that remote machine, when logged in with RDP?

To be clear (because it's a common mistake around the internet) - I'm not trying to redirect local USB device over RDP. The device is plugged into the target, remote machine and I cannot see it when I connect to it over RDP (and only then).

1

From what I read the Windows Terminal Services does not allow to use certain devices in a way I described in a question. Example of such device is a Smart Card reader (various kinds of hardware USB certificates/tokens).

For such devices it's only allowed to use the device at the computer where it is physically plugged in and eventually redirect it over RDP to remote machine, where it can be then used over RDP session.

Unfortunately it looks like such devices have to be plugged in locally to the RDP client, not server and tunneled (redirected) through RDP towards the server when connecting to it. There is no way to share it between different RDP accounts.

Unless anyone else proves me wrong in a day or two, I will accept my answer.

0

Depending on what client you are using for RDP might change it slightly, but the official from Microsoft:

For your issue I can suggest you to check group policy setting “Do not allow drive redirection” must be disabled under following path.

Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection

It may also help to use an account that has admin on that machine.

Scraped from:https://social.technet.microsoft.com/Forums/en-US/24ab3b8c-730d-4085-a69a-7626db39da10/local-client-drives-visible-but-not-accessible?forum=winserverTS

  • Guy from quoted article starts with following statement "I have a problem with mapping of local client drives when accessing a Windows Server 2012 machine via Remote Desktop.". I don't want to use my local device on remote host. I have a device plugged in physically to that remote host. Problem is I don't see it if I connect there with RDP. But I can see it just fine if I go there personally and log in to that computer from physical keyboard and monitor connected to that computer. – Googie Dec 12 '18 at 2:23
0

I know you asked for RDP.

But if you really need this device to work when you are connected remotely you can use any other remote connection options available like VNC, or even TeamViewer / Anydesk.

  • Yes, I was aware of that option. Problem with VNC is each connecting user will share the same session, or "screen". To have separate screens available per user I would have to setup as many vnc instances as there would be users of the system. That introduces other problems with maintaing this whole thing. – Googie Dec 17 '18 at 22:28
-1

1)Open Remote Desktop Connection, click Local Resource tab and More button, unfold device node. Please check if you choose all device letter.

2)Open Terminal Services Configuration, right-click RDP-tcp, choose properties. In Client settings, please check if disable device has been applied.

3)Run Rsop.msc on Terminal server and see if Do not allow driver redirection has been configured under computer configurations\Administrative Template\Windows Component\Terminal server\Device and Resource redirection

From: https://social.technet.microsoft.com/Forums/lync/en-US/2aa84bbe-4572-487e-bec3-69a56e4359e4/usb-devices-not-working-in-remote-desktop?forum=w7itpronetworking

  • I deliberately mentioned I don't mean redirection of local device over RDP into remote host. What you provided is solution exactly for that. – Googie Dec 12 '18 at 2:20

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.