0

I'm running Windows 10 Enterprise 2016 LTSB 64bit. Every time I try to install a software I get an BadImage error

enter image description here

I have tried to install different software (Firefox 32bit/64bit, Opera 32bit/64bit, 7Zip 32bit/64bit, Chrome) and always get the same error. I have tried all this as normal user or Run As Administrator with same result.

I have also try running sfc /scannow, but the scan never finishes and crashes after 83% with message: “Windows Resource Protection could not perform the requested operation”. I have also tried this in SafeMode.

Other thinks I've tried:

  • ChkDsk – error still there
  • Windows Reset – will not let me proceed
  • Windows Update – always fails
  • Dism.exe /online /Cleanup-Image /StartComponentCleanup finished with error "Component store has been corrupted"
  • I have downloaded image from our MSDN and tried to repair the image using Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:D:\sources\install.wim:1 /limitaccess but this has failed as well

The device came with OS pre-installed already and I do not have ISO image or the option to re-install the windows.

Any ideas how to get around this?

  • You can always use the Microsoft Media Creation Tool to create Windows installation media. – Daniel B Dec 12 '18 at 8:56
  • @DanielB if I try to install the software, I get same error. If I just unzip it, there are SetupHost.exe and DiagTrackRunner.exe, but they don't seem to run anything... – vidriduch Dec 12 '18 at 9:01
  • Then I suggest using a different PC to create a setup medium. – Daniel B Dec 12 '18 at 9:54
  • @DanielB see my update re: image repair – vidriduch Dec 12 '18 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.