0

I am having trouble while editing the registry to get a file type to open with a default text editing program. I have edited the registry following this post: https://superuser.com/a/1369178/972419.

However, after attempting to open the file, the correct program opens, but the file appears empty. When right click the file and using the open with option and selecting the same program, the contents of the file are available and editable also.

Is the file appearing empty because I'he committed some unknown error while I was editing the registry?

How do I get the file to open in the App in edit mode on double click?

  • 1
    It'd be a good idea to post a screenshot of what you've done in the registry; it's hard to say whether you've made an error w/o knowing what you've done. ;-) – Steve Rindsberg Dec 12 '18 at 17:00
  • We don't know what you did in the registry, but generally, the filename must be passed to the called application with a command line argument, usually a percent sign and a letter or number. Without that argument, it just opens the application. Notice in the linked answer that a number of entries use %1 in the command. – fixer1234 Dec 13 '18 at 5:17
  • @fixer1234 I realized this after adding the %1 to the registry command open path shortly after posting this yesterday and my problem was solved. thanks for the explanation because I didn't really understand why that made it work honestly – bronzelightning Dec 13 '18 at 17:43
0

In Windows, there should be a Control Panel setting called "Default Programs". It list files extension and the program associated with them. Find your file extension under this list and select it. Then select your program to open it with. You might need to find the file though as some executables are not listed by default so you will click "Browse..." and manually look for your executable that you want to handle said file extension.

  • 1
    this method does not work. The file type extension was not showing up because it is not a standard file type. Adding a "%1" to the end of the registry open command path seemed to fix the problem I was having. but thanks for the suggestion anyways!! – bronzelightning Dec 13 '18 at 17:40
  • Your welcome. What kind of extension were you trying to open if you don't mind me asking? Was it just a generic "File" you were trying to open? – KALI99 Dec 13 '18 at 17:50
  • 1
    It is a file for a laser engraving machine that ends with the file extension .bia – bronzelightning Dec 14 '18 at 18:31
  • Oh wow... Yeah that is NOT included by default, lol. – KALI99 Dec 14 '18 at 23:00
0

Right click the desired file ---> Open with ---> Choose another app ---> (now before selecting the program that you want to use) check the box beside Always use this app to open .abc files. After that you can double click the demanded program (or hit OK) to let the certain file become permanently open with your preferred app.

enter image description here

  • nah that wasn't working so I had to manually add the file extension in because it is a non-standard file extension. issue is resolved but thanks for the tippy – bronzelightning Dec 13 '18 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.