I just used Clean Install to reinstall on Windows 10 1809 (big mistake, I know). It's the official refreshed version, but it grants ALL APPLICATION PACKAGES permission to C:\Windows.old.

This is relevant because inheritance is sticking to all of the files, even in server mode. Any attempt to remove it looks as though it succeeds, but nothing happens.

These are all of my personal files and documents, appdata, etc, going back many years, so the relevant portion is about 200GB, so copying (which resets the modified date anyway) isn't really feasible.

I need to either

  • move the files and break the inheritance chain; tried this using old PowerShell trick (move file, reset inheritance via SetAccessRuleProtection; the phantom permission sticks from "Parent Object" which this normally negates),
  • remove the phantom permission before moving files.

I've already taken ownership of the folder, that's not helping any. To be clear, I want to remove the ALL APPLICATION PACKAGES permission from C:\Windows.old so my files aren't tainted with a bad security permission.

Screenshot of ALL APPLICATION PACKAGES, removing it "succeeds", but it's still there:


  • Let us continue this discussion in chat. Dec 13, 2018 at 3:54
  • This is usually a driver package. Removing the driver clears the lock. This question has been asked and answered here before. Did you check the other questions about windows.old? Dec 13, 2018 at 4:40
  • I checked other questions, there isn't a driver involved that I'm aware unless Microsoft is being stupid with one. Things aren't locked, there is no permission denied, removing "ALL APPLICATION PACKAGES" iterates through all of the files like usual, no errors, but the phantom permission stays. Same with cacls, icacls, powershell set-acl, etc. Dec 13, 2018 at 4:45
  • Another point: A "clean reinstall" typically involves formatting your hard drive prior to or during the installation process. If "Windows.old" still exists, that means you did not run a "clean reinstall". Could you clarify the precise method and steps you used to update your computer to build 1809? Dec 13, 2018 at 17:03
  • And finally, what are you actually trying to accomplish: Are you just trying to remove the All Application Packages permission entry from your own files (what the body of the question seems to say) or are you trying to delete Windows.old and you believe this permission is preventing you from doing so, or something else entirely? Please EDIT your question to make this more clear. Dec 13, 2018 at 17:04

1 Answer 1


You can follow the below steps for deleting the Windows.Old folder by login as administrator.

  1. Press the Windows + R keys to open the Run dialog, type cleanmgr, and click/tap on OK to open Disk Cleanup.
  2. If you have more than one drive or partition on your PC, then select the Windows C: drive, and click/tap on OK.
  3. Click/tap on the Cleanup system files button.
  4. If prompted by UAC, click/tap on Yes.
  5. Repeat step 2 above.
  6. Check the Previous Windows installation(s) box, and click/tap on OK.
  7. Click/tap on Delete Files to confirm.
  8. When Disk Cleanup finishes, the C:\Windows.old folder will be deleted.

Update: If you want to move the files from the Windows.Old folder, you may need to take ownership and grant full permissions to your account. This can be done by using the freeware TakeOwnershipPro.

  • I really obviously don't want to delete all of my personal files and documents, nor would that at-all help with the issue. Dec 13, 2018 at 3:09
  • @TheGoddessInari I've updated my answer. To solve the permission issue, you need to change the ownership of all files inside C:\Windows.old.
    – E.Swaff
    Dec 13, 2018 at 3:23
  • That was the first thing I tried. It's not about permission denied, or any other error, but a bad phantom permission that persists regardless of trying to remove it. Dec 13, 2018 at 3:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .