0

I have several keyboard shortcuts configured inside the i3 window manager, each of which is a two-key combination of Super+<key>. In addition, the MATE (Gnome 2 fork of Ubuntu) environment also listens for shortcuts which begin with the Super key. I've found that, when a shortcut is configured in the MATE environment, pressing the key combination once will have the desired effect- however if the shortcut is configured in i3, I need to press the second key twice- so Super+<key> <key>, releasing <key> in between. It seems to me that the Gnome2 environment is somehow taking precedence over i3, but it's not clear to me how, or how it can be corrected, or where exactly this precedence is implemented or how it can be controlled. What is leading to this behavior, and how can it be changed?

1

I was so annoyed by this behaviour. This is how I solved it:

  1. Open "Keyboard Preferences" in "System Setting"
  2. Open the "Layouts" tab
  3. Click on the "Options..." button at the bottom of the popup window
  4. Look for the submenu "Alt/Win key behavior"
  5. Change from "Default" to "Hyper is mapped to Win"
  6. Logout and re-login

i3 shortcuts now work properly.

  • Brilliant! Worked like a charm. – deftfyodor Dec 18 '18 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.