0

I have two drives, C: and D:. C: is the main hard drive, and D: is my external hard drive that is connected via USB.

On my computer, I'm able to access both \\localhost\c$ and \\localhost\d$ fine. However, when connecting from other devices, \\\10.0.0.8\c$ is a valid folder (as in allows me in with my correct credentials) while \\10.0.0.8\d$ replies with "Access Denied" no matter if a password was entered or not..

According to many reports, this seems to be a bug caused by a computer policy which enables the auditing object access over network, however - The setting in question is disabled; it's never been turned on at all. Point is, I can't turn it off because it is already off.

Others have suggested to rather use admin shares, use a regular share to any folder that isn't the root. Unfortunately, the "Access Deined" error still stands when trying to access a shared directory that was on the external drive D:. Even with full permissions, anything on D: would yield an "Access Denied" while anything C: would function just fine.

Symbolic links (remapping a C: folder to be simply an alias of said folder in D:) does not seem to work at all.

What could be causing this problem, and how would I allow access to my external drive? Could a different policy or some hidden Registry setting be causing it?


It's worth noting that I tried accessing with both another Windows 10 PC, and through my Android phone.


Update: So upon further investigation, the "Access Denied" message appears whenever:

  • The specified path does not exist, or:
  • An error occurred while accessing said directory, or:
  • The request was received successfully, but the response wasn't returned in full (ie. a mid-response disconnect), or:
  • The specified path exists, but you do not have permission to view it.

The equivalent of:

enter image description here

For the example above, it's the first point. A blank endlessly loading window appears for the third point.

The "Forbidden" message means that:

  • The specified path exists, and you do not have permission to access it.
0

In the discussion below, assure that you are using an administrator login for the actions below and for the access over the network.

Try to set LocalAccountTokenFilterPolicy:

The LocalAccountTokenFilterPolicy setting affects how administrator credentials are applied to remotely administer the computer.

This command, run as Administrator, will set this registry item:

cmd /c reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f

If this does not help, try to disable UAC Admin Approval mode:

  • Open the Local Security Policy application
  • Navigate to Local Policies > Security Options
  • Set to Disabled the policy User Account Control: Run all administrators in Admin Approval Mode.

The "Access Denied" message should now disappear if you try to access the D$ Administrative Share with a local account in the administrators group.

  • Nope. That's not it. It's already set to 1. Nice try. A setting of 0 returns a definite "Forbidden". Whereas 1 returns a vague "Access Denied". – aytimothy Dec 15 '18 at 0:09
  • Added another setting. – harrymc Dec 15 '18 at 10:28
  • Nice try again, still no. – aytimothy Dec 15 '18 at 10:47
  • You might need to disable UAC totally. Even if this will make it work, I would counsel to create your own share in parallel to D$, over which you will have full control, rather than disabling UAC. – harrymc Dec 15 '18 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.