0

Here's my setup.

2 Telus ADSL Connections at 2 seperate locations

Location 1 has a dsl modem and a TP-Link HL-R600VPN v4 (or whatever the latest is) Location 2 has an actiontec3200M and a TP-Link HL-R600VPN v1 (or maybe v2)

The actiontec router is setup in bridge mode.

The IpSec tunnel is there, file sharing works completely fine, however I cannot RDP from the computer in location 2 to the computer in location 1. The first time I try to connect, it gets as far as logging in and then hits a black screen and eventually times out. When I try to reconnect, I get an internal error on the RDP program.

When I first set this up, i was able to connect but once I disconnected and tried to connect again, the same thing would happen with the black screen and then internal errors with successive attempts. It seemed as if i rebooted computer from location 1, i could connect again one time. At another time, i tried again several hours later without rebooting and it worked one time but failed the next. However in the last couple of days, it does not work at all.

Here's some other things I've noticed.

From location 2, i can access both routers at both locations using their local addresses.

From location 1, i cannot access location 2's router. This may be that the router is just blocking outside access or a symptom of what's causing the RDP issue.

If i open up port 3389 on the PC at location 1 and connect through RDP from the computer at location 2 using the WAN ip, it works every time.

Also, I cant remote to the computer in location 2 from the computer in location 1 using the LAN

Any thoughts?

  • Here's some more info after more testing: I setup file shares on both computers. Location 2 PC can access Location 1 PC but Location 1 PC can't access Location 2 PC. Location 2 PC can ping routers from both locations and computer from Location 2. Location 1 PC can ping it's own router but but location 2 router or location 2 PC. – Richard Chase Dec 14 '18 at 23:16
  • Sounds like a NAT problem. You sure you set your tunnel up properly? Sounds like one of your routers is NATing the traffic and it’s causing routing issues as well. – Appleoddity Dec 15 '18 at 0:52
  • This is a case for Wireshark. Be sure to update the firmware of all devices along the path. Then do some deep analysis. It would be ideal to capture a success and watch what happens when you close the RDP connection. – HackSlash Dec 17 '18 at 16:29
  • I assume that it's setup properly. In the last few tests I've done, its worked a few times and then all of a sudden when I try to connect again, I get the black screen, kicked out and then internal error again. Seems to be hit and miss. Firmware is updated on all devices however one of the routers is fairly old so we've ordered a replacement to see if that is the issue. I attempted to put in a plain speedtouch DLS modem instead of the ActionTec device but it would not get a dsl signal. I assume their connection doesnt support those modems. What is Wireshark? – Richard Chase Dec 18 '18 at 17:34
0

So as it turns out, it was just a faulty VPN router. We ordered a replacement, installed it with the same settings and it's working flawlessly. Thanks everyone.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.