0

I have achieved the desired vlan settings on my Asus router by using robocfg. However, when I reboot the router those settings are lost. I'm running the latest firmware as of this writing (3.0.0.4.384_45149).

robocfg vlan 22 ports "1t 3u"
robocfg vlan 1 ports "1 2 4 5t"

Searching around on forums, people are suggesting that settings can be persisted by writing scripts and storing them in the folder /jffs/scripts/. It also says that this feature needs to be enabled in the UI under Administration -> System. However, in my version of the firmware I do not see any settings regarding scripts or jffs settings.

Here is the script I have created at /jffs/scripts/services-start

#!/bin/sh
touch /tmp/000vlanconfiged
robocfg vlan 22 ports "1t 3u"
robocfg vlan 1 ports "1 2 4 5t"

I also tried /jffs/scripts/post-mount and that didn't work either. The vlan settings are unchanged and the file was not created in the tmp folder.

0

The commands look good for me. Did you set the proper file permissions?

I'd guess you are missing the "execute" permission. Try to chmod 755 your services-start file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.