1

I have a Brother MFC-L2700DW. I am trying to set it up on my Linux Ubuntu 16.4. I have installed the driver, and the printer appears in settings. It is also connected via my wireless router, and I can see it in my router settings.

I have just added the printer to a new laptop running Ubuntu 18.4. It installed and connected flawlessly the first time. I use it wirelessly going through my Sagemcom F@st 5260 router.

Why would the work on one and not the other? Properties have:

Description: MFCL2700DW
Location: *blank*, i.e. empty
Device URI: file:///dev/null
Make and Model: Local Raw Printer
Printer Status: Idle

The same properties on the working computer are:

Description: *blank*
Location: *blank*
Device URI: ipp://BRW70778128A937.local:631/ipp/print
Make and Model: Brother MFC-L2700DW series, driverless, cups-filters 1.20.2
Printer Status: Idle

For some reason I have this printer defined twice, the other settings are:

Description: MFC-L2700DW
Location: *blank*
Device URI: dnssd://Brother%20MFC-L2700DW%20series.ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-30055cafa9b
Make and Model: Brother MFC-L2700DW for CUPS
Printer Status: Idle

Yes, I know that the file:///dev/null is the elephant in the room, but I don't know what would belong there or even how to generate that file for this particular computer.

Help/suggestions would be super appreciated.


Update 12/25/18 .... Per advice I ran

sudo dpkg -i --force-all mfcl2700dwlpr-3.2.0-1.i386.deb

and verified with:

dpkg -l | grep Brother ii brscan-skey
0.2.4-1 amd64 Brother Linux scanner S-KEY tool ii brscan4
0.4.6-1 amd64 Brother Scanner Driver ii mfcl2700dwcupswrapper:i386
3.2.0-1 i386 Brother MFC-L2700DW CUPS wrapper driver ii mfcl2700dwlpr:i386
3.2.0-1 i386 Brother MFC-L2700DW LPR driver ii printer-driver-brlaser
3-5~ubuntu1 amd64
printer driver for (some) Brother laser printers ii printer-driver-ptouch 1.4-1
amd64 printer driver Brother P-touch label printers

According to

https://support.brother.com/g/b/downloadhowto.aspx?c=us&lang=en&prod=mfcl2700dw_us_eu_as&os=128&dlid=dlf101791_000&flang=4&type3=559

I should have the commands...

/etc/init.d/lpr  restart 

/etc/init.d/lprng  restart

...to run, but I have neither. Quite odd, because my other computer, the one the printer works correctly with also does not have lpr or lprng.

update 12/26/2018 --- ! solved see answer below ! ------------------------------------

  • I think the file. Is just a standing for a URI for the printer. Have you tried replacing it with ipp://BRW70778128A937.local:631/ipp/print or ipp://IP.add.re.ss:631/ipp/print ? – davidgo Dec 16 '18 at 3:06
  • Thanks @davidgo, the former, ipp://BRW70778128A937.local:631/ipp/print got my printer's attention right away, unfortunately it kept printing blank pages. The later ipp://IP.add.re.ss:631/ipp/print could not connect to the printer. The processing window's status on the job reads: Processing - Not connected? – Joe Molnar Dec 17 '18 at 4:39
  • Ok, that's good in as much as it means you are now communicating with the printer. You will need to correct the make and model as it is printing in "raw" format. – davidgo Dec 17 '18 at 5:46
  • Hi @davidgo, I followed directions on the Brother page. [support.brother.com/g/b/…, Ran the command: sudo dpkg -i --force-all mfcl2700dwlpr-3.2.0-1.i386.deb I edited /etc/printcap according to instructions. But, I do not have the programs '/etc/init.d/lpr' or 'lprng' – Joe Molnar Dec 26 '18 at 1:28
  • 1
    Will do, and done, @fixer1234! – Joe Molnar Dec 29 '18 at 15:10
1

How I got the Brother MFC-L2700DW printer to work with my desktop Ubuntu server 16.4 LTS when it hadn’t been able to work despite working on my new laptop at 18.04.1 LTS.

I’ve already downloaded from Brother site the install package. This is Generic CUPSwrapper printer driver. https://support.brother.com/g/b/downloadhowto.aspx?c=us&lang=en&prod=mfcl2700dw_us_eu_as&os=128&dlid=dlf101791_000&flang=4&type3=559

(This is after previously going through the driver install tool at: https://support.brother.com/g/b/downloadend.aspx?c=us&lang=en&prod=mfcl2700dw_us_eu_as&os=128&dlid=dlf006893_000&flang=4&type3=625)

The instructions tell me to enter: dpkg -i --force-all (lpr-drivername) For me, that was: dpkg -i --force-all mfcl2700dwcupswrapper-3.2.0-1a.i386.deb I wasn’t sure which lpr driver name they refer to, it was the exact package name as in the download, not unpackaged or installed.

This still not do the trick. Only mentioning what I did so far to get to the current state of my system. The rest of the instructions on that download page did not apply, e.g. names of commands in step 3 did not exist.

I found the page http://localhost:631/ This is the cups page. At first I did not know what to do with this so I ignored it for some days while trying other hacks. Then I stumbled upon this page https://www.blackmoreops.com/2013/11/15/install-configure-printers-linux-cups-foomatic-db/ which fully explained.

On cli: sudo apt-get install cups cups-client "foomatic-db" sudo adduser root lpadmin sudo adduser joe lpadmin (that’s me, substitute your own account name) service cups restart

on browser go to: http://localhost:631/

Click CUPS for Administrators → Adding Printers and Classes → Add printer → Brother MFC-L2700DW was found on Discovered Network Printers→ prompt to enter User ID and password → prompt to select printer. → Add printer screen, enter human readable Name, Description, Location, click Share this printer, click continue → Brother MFC-L2700DW

This worked the first time around, whereas I had been pulling my hair for months, attacking this problem in half hearted ways on and off.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.