0

I have Thunderbird installed in /opt directory (I installed it few years ago in this directory) but now with a new Thunderbird upgrade I can't see any of my emails and account stored in /home/username/.thunderbird/profile.default. When I fire up Thunderbird it behaves as I don't have any profile set and ask to create a new account and so on. How can I make Thunderbird load my existing profile ? Appreciate some help, Vladi folder with a profile

profiles.ini configuration PS: OS Xubuntu 16.04.5 , Thunderbird 60.3

  • Did you originally install Thunderbird from the repository or manually install it? – fixer1234 Dec 21 '18 at 12:19
  • @fixer1234 I had installed manually Thunderbird in /opt directory. – vladimir pavloski Dec 21 '18 at 20:19
  • Let me know if the answer doesn't solve it. Thought of another potential cause. – fixer1234 Dec 21 '18 at 23:57
0

You have two profiles, both of which have been modified, so we can't tell from the names which was the original. I suspect Thunderbird got installed again instead of upgraded and created a new profile (unless you were experimenting). Both profiles should appear in profiles.ini.

If you have a number of email accounts and/or created some mail folders in your original profile, you should be able to identify which profile is the original by looking at the subdirectories under the two profiles. Under the Mail folder of one of the profiles, you should find your accounts and mail folders. Assuming the other profile was your original:

  • I'm not sure this step is required, but just in case, rename the other profile filename extension from default to vladi (so 4gb3v5vo.vladi).

Edit profile.ini:

  • Change the StartWithLastProfile value from 1 to 0.
  • Edit Profile0, changing the Default value from 1 to 0.
  • Add Profile1, using Profile0 as a template (copy and paste then edit).
  • In Profile1, replace the Name value with vladi; you can always change the names later, they're just labels, but each profile should have a unique name.
  • Replace the Path value with the other profile string (4gb3v5vo.vladi).
  • Set the Profile1 Default value to 1.

Assuming the other profile is your old one, that should give you access to it the next time you start Thunderbird. However, don't tell it yet to always use that profile.

If it isn't your original profile, it could be that Thunderbird got lost in its underwear. In that case, try restarting Thunderbird and selecting the profile named "Default".

Once you identify your original profile, you can set that one as the default (which you should be able to do in the Thunderbird startup dialog), and you can also tell it to always use that profile. Once that's done, you can delete the unused profile.

You can also access these controls via Help | Troubleshooting Information, last item under Application Basics at the top: About:Profiles. You can also restart with a selected profile from here.

  • the profile 4bg.......default was my default profile with all my mailboxes and emails and of course my accounting settings. The second profile rdk....default was created automatically by TB, then I copied the content of 4bg...default profile to this new one (rdk......default), but no success. – vladimir pavloski Dec 21 '18 at 20:30
  • I'll try your suggestion . – vladimir pavloski Dec 21 '18 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.