0

So, I've just bought a Lenovo USB-C hub (port replicator) which I want to use with my laptop and desktop computers. However, neither of my devices has USB-C ports and I can only use USB 2.0 or USB 3.0 ports with an adapter.

The hub in question is: https://www.amazon.co.uk/gp/product/B07FQD4KMV

The adapter in question is: https://www.amazon.co.uk/gp/product/B01J16IOIS

Turns out that my initially planned setup doesn't work. I'm not sure why but my guess is that the conversion of USB-C to USB-A renders the hub undetectable for Windows 10.

I had concerns whether either the hub or adapter are not functioning properly but after tests with other devices I concluded the problem is with the USB ports on the laptop and desktop.

Do you have any ideas how I can bypass this issue? I am thinking as last resort I may have to buy and install PCI Express USB-C adapter card on the desktop but I am clueless on what to do with the laptop.

  • 1
    When you say "devices" in the first paragraph, do you mean that neither of your computers has a USB-C port? – Christopher Hostage Dec 17 '18 at 22:09
  • USB standards are a complete mess right now. – Keltari Dec 17 '18 at 23:09
  • @ChristopherHostage indeed, neither my laptop nor my desktop have USB-C ports – kr3t3n Dec 19 '18 at 0:19
1

You have purchased a pretty sophisticated "port replicator", which is more like a "docking station", and it has a lot of auxiliary functionality like Power Delivery to charge a laptop "in reverse" (aka "accessory adapter"). This functionality requires full-blown PD communication over Type-C "CC channel", which employs sophisticated serial protocol. The female port (in normal modern laptop) must be able to communicate and respond properly.

To communicate over CC lines and have the Type-C port "flippable", the female receptacle must have serious electronics inside, at least a CC-PD controller, and a super-speed port swap multiplexer. It also must include a port power switch to be compliant with Type-C specifications (no VBUS unless connected), while classic USB ports have VBUS opwer always on.

Your "adapter", however, doesn't look like having any electronics at all, just a goofy cheap mechanical adapter, with no power switch and no responses to CC commands. That's why it doesn't work with a sophisticated port replicator. Maybe, only maybe some primitive USB devices will work with this dongle, but any serious multi-functional dual-role USB links won't. You need to examine this dongle for functionality and compliance to Type-C specifications, and likely need to get a better Type-A to Type-C converter.

  • Thanks for the explanation. I only tried the adapter with a memory card reader and it worked, thus I assume it works in general. Can you recommend an adapter that would be sufficient in my situation. Also, would it ever work with USB 2.0 port at all? – kr3t3n Dec 19 '18 at 0:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.