2

Windows Server 2008 R2

When typing anything (or nothing) into PowerShell, and hitting enter it just locks up with a flashing cursor and does nothing for about 20 to 30 minutes. After waiting a long time, PowerShell works, it just takes a long time to initialize.

  • I've installed Windows Management Framework 4.0 and rebooted
  • I've tried SFC scan (no issues found)
  • I've tried from a different user profile
  • I've tried with the -noprofile switch
  • I've tried with different PowerShell versions with the -version switch
  • PSModulePath=C:\Windows\system32\WindowsPowerShell\v1.0\Modules\

Another thing I've noticed is that when starting version 1.0 or 2.0, I don't even get a command prompt, just a Windows PowerShell Copyright and a flashing cursor.

Everything else on the server works fine!

PSVersionTable: Major Minor Build Revision

4 0 -1 -1

  • Is this a domain member server or standalone playing server? Is the server a VM and when you did your pristine build, did you create a snapshot? What role is the server playing? If this is real hardware, after you pristine build, did you do a full back up and capture the system state? If none of the above are true, you may be in a rebuild from scratch, or deal with the delay, as this sounds like a full environmental issue. – postanote Dec 18 '18 at 3:47
  • Domain member. It's actually the primary DC – Xebozone Dec 18 '18 at 3:48
  • Completely rebuilding from scratch seems pretty extreme without any troubleshooting. If it was such a serious issue you would notice other issues as well. Have you checked the event logs? Do you notice any other delays or issues with the server? Any hardware diagnostics done? I notice powershell always takes some time to initialize when I start it. I’ve found that I often have to press enter to kick start it and get a prompt. I imagine there is something it is doing and it just happens to be more problematic for you. – Appleoddity Dec 18 '18 at 4:24
  • Possible duplicate of Powershell very slow to open/respond – Appleoddity Dec 18 '18 at 6:14
  • I believe that caching was an issue. I noticed that after leaving PowerShell to load, and waited, it seemed to speed up the subsequent time. I applied that script as above, which should hopefully help. Will keep an eye on things. Thanks for the support so far – Xebozone Dec 20 '18 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.