0

We're running into an issue in IIS where we have 1 site started (http), with a binding of * on 10.xx.x.28:8082 (http). We have a second site, but this one is https with a different IP, binding is * on 10.xx.x.35:8082 (https).

When we try to start the https site, we are getting "This website cannot be started. Another website may be using the same port."

Screenshot

  • How have you assigned two IP addresses to the same computer? Have you bound both to the same certificate? – harrymc Dec 18 '18 at 14:20
  • Only the https binding has the certificate. The other IP is http. – sonicseahawk Dec 18 '18 at 15:04
  • Check the definitions of the websites. I suspect they are not as simple as stated. You will need to add screenshots of the settings to the post. – harrymc Dec 18 '18 at 15:28
  • If I have both IP's set as http with the same port the sites start just fine. But as soon as I change one of the IP's to https and assign the certificate the problem arises. I'm not sure if it's a certificate issue, or just the fact that if we have 2 IPs going through the same port with one being http and the other https causes the issue. – sonicseahawk Dec 18 '18 at 15:30
  • I've added a screenshot above, as soon as I make those ports the same I run into the issue. – sonicseahawk Dec 18 '18 at 15:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.