0

My problem

I am trying to open a command prompt like this:

Step 1

press windows+run

Step 2

Write cmd

Step 3

Press enter

Result

Cmd briefly opens then closes

Causes

Recently i had a malware but i cleaned it with MalwareBytes, still this could be a follow-up of that

Other weird behaviour

  • When i go to `windows/system32` and I right click `cmd.exe` to see it's properties it doesn't allow me to do it, acts just like if I would have clicked away, on the other hand i can see the properties for other files
  • If i right click the start icon and run command prompt from there it allows me to use cmd perfectly
  • I can't open `.cmd` files

What I've tried

  1. I ran `sfc` for cmd and it closed my command prompt
  2. I checked `HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor` for any autoruns but i found none
  3. I checked with the program `autoruns` if there are any autoruns on the cmd and i couldn't found any

Any help is highly appreciated!

  • Sounds like a virus. Try booting into safe mode and see if things run normally. – duct_tape_coder Dec 19 '18 at 21:32
  • I think you can refer to this article: stackoverflow.com/questions/5373137/… – Peter.G Dec 20 '18 at 6:56
  • everytime I try to acess the link you posted my browser closes? I'll do another scan to see if I find something – Radu Dec 20 '18 at 10:35
  • Also when I start it in safe mode cmd opens with no problem – Radu Dec 20 '18 at 10:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.